summaryrefslogtreecommitdiff
path: root/dev-ruby/bson
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/bson
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/bson')
-rw-r--r--dev-ruby/bson/Manifest5
-rw-r--r--dev-ruby/bson/bson-4.2.2.ebuild44
-rw-r--r--dev-ruby/bson/bson-4.3.0.ebuild44
-rw-r--r--dev-ruby/bson/metadata.xml11
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-ruby/bson/Manifest b/dev-ruby/bson/Manifest
new file mode 100644
index 000000000000..e24f261e862e
--- /dev/null
+++ b/dev-ruby/bson/Manifest
@@ -0,0 +1,5 @@
+DIST bson-4.2.2.tar.gz 96725 BLAKE2B 62c40df519e185665f0c42bc8ab6a2d8472d123397f1ed1403e40254944cd423e6cedbfa014a03f6c6ed8a7cde94f8c26d06e784b82ea55f17a97996915381d6 SHA512 4de8950271f5fdd5927eda290b6506248012cb8a932d65773ad53f1e3e4c67ea17575b559447d5eb6c9286f672439879dbc89aa0cded4ec2d0fa35c49da7a574
+DIST bson-4.3.0.tar.gz 103341 BLAKE2B 29f7d870ce85e4984f47fda482b9ebc33986332eefcc3d9c5d56f7cc628e698a4a2e879225b81c6d0b1edc9e62f9b426f2510b67b51398a699d96de390544efb SHA512 c753bd68df5871a7cbed78dc68791a5d1c30db5975b70702742f12373afb754df8078d2bc6a772fd398815bca05a2fa020cc820a1ea9238f8b01eb492581b17f
+EBUILD bson-4.2.2.ebuild 1078 BLAKE2B 621d2c66b6c5f941fa2279b6a534d232020069aa1ba55ad256e912945c51c73b823d486190679b47f33282bc947a15ed9d01117be35aa55394cb9adef64c8744 SHA512 d74d592a22fa0e30b90999478eb850f2d291118cb1bef2a8fa7af6fab934f20c46ba4ec91fa6a947302139ce9758d60cf004d3ed1604af3fc2dbcade09f4df80
+EBUILD bson-4.3.0.ebuild 1071 BLAKE2B c9b5ad65853b9785c3dc6b9742e12541b66b72bb3dfd9aa3180a1c7f0e8df9af18327c5d57da42dcd37fb254c32687da40bb416c5c8e4124b7e9db39a0dd0802 SHA512 c75607cb669ff83a7de59db486d8057e8865c3f1c1c21cf4c87a4400924b411d391248157de4f66304a7ecff5f8212df1e23ceae356e3b3efb81538db853ee16
+MISC metadata.xml 343 BLAKE2B 45b4f3d9d5e86b9fee94d0b51c420d48c51b914adb49585c12519a81de40c555bc5ed48b03b751c7ab524464e46836a25d51f824c56cb03837f61ae071e1517b SHA512 a5fdde2808fc5c77be1a62a593215b8b619f53ffd8606e76db34a2eb2006deea409c64e85d6ba8a5b4089133265b6911188a9026c3698b44270ef8ce1f12967f
diff --git a/dev-ruby/bson/bson-4.2.2.ebuild b/dev-ruby/bson/bson-4.2.2.ebuild
new file mode 100644
index 000000000000..115c776b44fb
--- /dev/null
+++ b/dev-ruby/bson/bson-4.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/bson/bson-4.3.0.ebuild b/dev-ruby/bson/bson-4.3.0.ebuild
new file mode 100644
index 000000000000..65464f572e20
--- /dev/null
+++ b/dev-ruby/bson/bson-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}
diff --git a/dev-ruby/bson/metadata.xml b/dev-ruby/bson/metadata.xml
new file mode 100644
index 000000000000..62dbcb87bba2
--- /dev/null
+++ b/dev-ruby/bson/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mongodb/bson-ruby</remote-id>
+ </upstream>
+</pkgmetadata>