summaryrefslogtreecommitdiff
path: root/dev-ruby/bluecloth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/bluecloth
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/bluecloth')
-rw-r--r--dev-ruby/bluecloth/Manifest5
-rw-r--r--dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild57
-rw-r--r--dev-ruby/bluecloth/metadata.xml8
3 files changed, 70 insertions, 0 deletions
diff --git a/dev-ruby/bluecloth/Manifest b/dev-ruby/bluecloth/Manifest
new file mode 100644
index 000000000000..506b560b146e
--- /dev/null
+++ b/dev-ruby/bluecloth/Manifest
@@ -0,0 +1,5 @@
+DIST bluecloth-2.2.0.gem 94208 SHA256 b30128433f6a83909b0cb52c3e001ee002ca8760d9b433ecc5ced308f7e703f9 SHA512 498ffc9eddd47ded1df5c60e8ae8647de1e0376c7787c42dad2450c15a237b01a734bd0a2742c56cb59831cddc5b35c88e954abc0a087fc803ce4890c07c2852 WHIRLPOOL d953b32ce79ef2d39bfba162bef30bd304c744f20a9d7cc81979b656d769624c33ae3b30141f1affc3729c11904e300ce1d9037e97cb6dbac7470c61da32b721
+EBUILD bluecloth-2.2.0-r3.ebuild 1182 SHA256 90693942048236c9a7778cea7f32fbfd7831973d4fa18245dce8630f0f86e223 SHA512 4b3718d63e2772d0dfb8e4e81706b63b7706846038fe2106428bb75f45ff617b9b06d19f9efff64c86cfd7551dd5d481c6113707a2eccb03be04f152dc9152e9 WHIRLPOOL b38d6115c3cf26e07641a2b9f8b0ae5b93078373fa58f3ce0dcb34bcb9a1daebe271deda81d6d5bbc8f5106bb5027222a5088e08fa64598fbd73dc76884718cb
+MISC ChangeLog 3788 SHA256 7895d7a3b430452376a90da34a61167416628aec3acb61726f50006a94407340 SHA512 32ef2f9885ffa997fca33843c0af8ce24fc3133e26049809eb8c093acfe22bd0cabdee169a6d0576069f5fd8e20835ddcfc41f885cd58adb045f8a2bf73e97ef WHIRLPOOL 786177bb9fdd454a768ac8dc1374aed35eb37ab528fcc22e7c25c8ea2d9241c664344a50e9fddb43d07a01f42ef0143a712244b6a71ecc71d952d86d1251d739
+MISC ChangeLog-2015 11424 SHA256 cfd482468dbf0d9cb8596d524f85b06d9cf7e2c6897a6ac130eb4221574ba80d SHA512 ff8c4c181ee759a4d0a8af538cb4692070c49b3eed98f7794f62fdebd7a7d760df26f2ad91d5b3cc92014fcb348320e828d5fb096d3a1c9d14478bb718963d49 WHIRLPOOL e5962899b43ed377719425b97d74713d8b1d0022c422848312025c0b00ab9a4c735420b851da0d56eb3ae5d5027ebfd33eb7dea2e1620d13446dee6d14a032c7
+MISC metadata.xml 247 SHA256 1236c1552dc683658bd5bc3c5f880b71d9dfa13025edab4a0f8973f9eaa6bcf5 SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09 WHIRLPOOL c1aa829db3553d79fe71a8bf79fd6ea24e9fff4e591a4ade3c05e2a97b0df352170fbce76450c0402ec6d8998951c2f3eb3e198ac4638c0e0882208b9f4d8fc8
diff --git a/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild b/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild
new file mode 100644
index 000000000000..ab8bdd46a337
--- /dev/null
+++ b/dev-ruby/bluecloth/bluecloth-2.2.0-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit multilib ruby-fakegem eutils
+
+DESCRIPTION="A Ruby implementation of Markdown"
+HOMEPAGE="http://www.deveiate.org/projects/BlueCloth"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+DEPEND+=" doc? ( dev-lang/perl )"
+
+ruby_add_bdepend "
+ dev-ruby/hoe
+ test? (
+ dev-ruby/diff-lcs
+ dev-ruby/tidy-ext
+ )"
+
+all_ruby_prepare() {
+ # for Ruby 1.9.2 and 2.2.x compatibility
+ sed -i -e '1i $: << "."' \
+ -e 's/Config/RbConfig/' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+all_ruby_compile() {
+ pod2man --center --release --name bluecloth --utf8 bluecloth.1.pod bluecloth.1 || die
+
+ all_fakegem_compile
+}
+
+each_ruby_compile() {
+ emake -Cext
+ cp ext/bluecloth_ext$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ doman man/man1/bluecloth.1
+
+ all_fakegem_install
+}
diff --git a/dev-ruby/bluecloth/metadata.xml b/dev-ruby/bluecloth/metadata.xml
new file mode 100644
index 000000000000..28ab0c15f206
--- /dev/null
+++ b/dev-ruby/bluecloth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+</pkgmetadata>