summaryrefslogtreecommitdiff
path: root/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-11 09:12:41 +0000
commit343a7272d559a21a0e0ed13cb743fabb2bfcc479 (patch)
treedb03f20672a6244296ccc2aa27e70757937eb9f7 /dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
parent456dbeaab3e2f71f527eae542ab44d1e372b0655 (diff)
gentoo resync : 11.01.2018
Diffstat (limited to 'dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild')
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
new file mode 100644
index 000000000000..1235b94b1690
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-0.8.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -rubygems -a -q || die
+}