summaryrefslogtreecommitdiff
path: root/dev-ruby/awesome_print
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/awesome_print
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/awesome_print')
-rw-r--r--dev-ruby/awesome_print/Manifest3
-rw-r--r--dev-ruby/awesome_print/awesome_print-1.8.0.ebuild39
-rw-r--r--dev-ruby/awesome_print/metadata.xml11
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/awesome_print/Manifest b/dev-ruby/awesome_print/Manifest
new file mode 100644
index 000000000000..8d4b5f227ce0
--- /dev/null
+++ b/dev-ruby/awesome_print/Manifest
@@ -0,0 +1,3 @@
+DIST awesome_print-1.8.0.tar.gz 42605 BLAKE2B d401732991486349b17c2c6947c6674f715cbd33b2987c725a589504d8333e75b7428a9ca5897dcc1d5eacb7a74d7f7f5da84bbd23706e4c43c316718eead858 SHA512 72ac5c4d918c84adba5ea7a60502ac89d57c5734b0b557d0171caae86b5f13ce316c5d7717315ff56c7f7a0959efeb244b6b85f4147c14ec8bf9e128488cf480
+EBUILD awesome_print-1.8.0.ebuild 978 BLAKE2B bebd891855efd33c745681de0a0889a9814bdc76ef5a39fe7436ab9e97bc3a5489d4530315df24296d90ab194b93718727c0d4f9468a43b7f4558183158785ad SHA512 797e2d381d60792e1110c7acc2c9c60842b4030b377327effb44b147f900f48a390030d8bc4bc216166ec6d9eaac8496d74ea6112f18c85c6bc200f84d230b7d
+MISC metadata.xml 349 BLAKE2B cf59b75cfb3ae5739496b1dc23a05dbabe0622649335216e8137ba61a6cea03db4cdc8ebb5e5a1606f1812feace93bf8578be745b75512fdf33fd37ed0974245 SHA512 a7f845e4bfffe6b31927d6b15e797a8de970ddf242dd0ec2807471ca58e40dc4119b660b4d837c68d450fea8eda73cffa53b05eb87839c0f3138aec7baa3aef4
diff --git a/dev-ruby/awesome_print/awesome_print-1.8.0.ebuild b/dev-ruby/awesome_print/awesome_print-1.8.0.ebuild
new file mode 100644
index 000000000000..17c44c42876f
--- /dev/null
+++ b/dev-ruby/awesome_print/awesome_print-1.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library to pretty print Ruby objects in full color with proper indentation"
+HOMEPAGE="https://github.com/awesome-print/awesome_print"
+SRC_URI="https://github.com/awesome-print/awesome_print/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/codeclimate/I s:^:#:' \
+ -e '/simplecov/I s:^:#:' \
+ spec/spec_helper.rb || die
+
+ # Avoid activerecord specs since they don't run
+ # consistently accross rails versions and not all
+ # arches have rails
+ rm -f spec/ext/active_record_spec.rb || die
+}
diff --git a/dev-ruby/awesome_print/metadata.xml b/dev-ruby/awesome_print/metadata.xml
new file mode 100644
index 000000000000..1a4d4a7154d2
--- /dev/null
+++ b/dev-ruby/awesome_print/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">michaeldv/awesome_print</remote-id>
+ </upstream>
+</pkgmetadata>