summaryrefslogtreecommitdiff
path: root/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-07 10:28:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-07 10:28:02 +0100
commit24beafaaa74162a20d550f2ee7c4997724e34d95 (patch)
tree837cc95f211fd637e2a0b4f52355baf389f58db1 /dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild
parent2fe3545788a28893084c9f3b6f992cff1230505e (diff)
gentoo auto-resync : 07:09:2023 - 10:28:01
Diffstat (limited to 'dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild
new file mode 100644
index 000000000000..8f557b93f687
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-10.4.15.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="autoprefixer-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+SRC_URI="https://github.com/ai/autoprefixer-rails/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+DEPEND+="test? ( net-libs/nodejs )"
+
+ruby_add_rdepend "dev-ruby/execjs"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/rails-5.0.0
+ dev-ruby/rake
+ dev-ruby/rspec-rails
+ dev-ruby/sprockets-rails
+)"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/ s:^:#:" \
+ -e '/config.sass/ s:^:#:' spec/app/config/application.rb || die
+ rm -f spec/rails_spec.rb || die
+}