summaryrefslogtreecommitdiff
path: root/dev-ruby/async-io/async-io-1.34.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-23 03:49:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-23 03:49:35 +0100
commit850d399c4f1568d3c6d013d7f4e2e371c0118bd6 (patch)
tree37fe91f80d4b072d27976558c05df3503c196e85 /dev-ruby/async-io/async-io-1.34.0.ebuild
parent7b77dd2858b06e4a9367ca16d4c24aacb119b142 (diff)
gentoo auto-resync : 23:10:2022 - 03:49:35
Diffstat (limited to 'dev-ruby/async-io/async-io-1.34.0.ebuild')
-rw-r--r--dev-ruby/async-io/async-io-1.34.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/async-io/async-io-1.34.0.ebuild b/dev-ruby/async-io/async-io-1.34.0.ebuild
new file mode 100644
index 000000000000..75b432695d8b
--- /dev/null
+++ b/dev-ruby/async-io/async-io-1.34.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRA_DOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="Provides support for asynchonous TCP, UDP, UNIX and SSL sockets"
+HOMEPAGE="https://github.com/socketry/async-io"
+SRC_URI="https://github.com/socketry/async-io/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/async"
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/async-container-0.15:0
+ >=dev-ruby/async-rspec-1.10:1
+ dev-ruby/rack-test
+)"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ sed -i -E 's/require '"'"'covered\/rspec'"'"'//g' "spec/spec_helper.rb" || die
+}