summaryrefslogtreecommitdiff
path: root/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/astrolabe/astrolabe-1.3.1.ebuild')
-rw-r--r--dev-ruby/astrolabe/astrolabe-1.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild b/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
new file mode 100644
index 000000000000..61abe54ff9fb
--- /dev/null
+++ b/dev-ruby/astrolabe/astrolabe-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An object-oriented AST extension for Parser"
+HOMEPAGE="https://github.com/yujinakayama/astrolabe"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/parser-2.2.0_pre3"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ # Fix Specs until RSpec3 is available
+ sed -i -e "/mocks.verify_partial_doubles/ s/^/#/" spec/spec_helper.rb || die
+ sed -i -e "s/is_expected.to/should/" spec/astrolabe/node_spec.rb || die
+}