summaryrefslogtreecommitdiff
path: root/dev-ruby/ast/ast-2.4.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 12:18:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 12:18:12 +0000
commita18f8581f716592db51c45679c46e319db13ca29 (patch)
tree74125f25c6d522f24e2577328ab2c9f83b35eac2 /dev-ruby/ast/ast-2.4.2-r1.ebuild
parentc24da107a8903eb6e86d811f19448c01fa81ba15 (diff)
gentoo auto-resync : 14:03:2023 - 12:18:11
Diffstat (limited to 'dev-ruby/ast/ast-2.4.2-r1.ebuild')
-rw-r--r--dev-ruby/ast/ast-2.4.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/ast/ast-2.4.2-r1.ebuild b/dev-ruby/ast/ast-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..232bf9075596
--- /dev/null
+++ b/dev-ruby/ast/ast-2.4.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ast.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+SRC_URI="https://github.com/whitequark/ast/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}