summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-03 08:36:22 +0000
commitf65628136faa35d0c4d3b5e7332275c7b35fcd96 (patch)
tree021998302365c5652e37824b6c26d4d969a62055 /dev-ruby/asciidoctor
parent70b82ae359a5538711e103b0e8dfb92654296644 (diff)
gentoo resync : 03.11.2018
Diffstat (limited to 'dev-ruby/asciidoctor')
-rw-r--r--dev-ruby/asciidoctor/Manifest2
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.8.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index 5f1abd6a1528..496e72647edd 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1,3 +1,5 @@
DIST asciidoctor-1.5.7.1.tar.gz 565182 BLAKE2B c697ea1b371a9ec26ec3277e043275ed3672bad104d34553aa442723797df3cc4e5a48447f806dba53fb3a142760f514bff74b189058260f621c8b63f8ad02b1 SHA512 4819aef93fb301e5378871935370fe37671446ecdedf76853cc0c19a6a5f3f0e2debbf2afb8ba7287f866fb57903abdfe6d845e1ccf24dda4347ec9c92624c3d
+DIST asciidoctor-1.5.8.tar.gz 583484 BLAKE2B f0c654c5e43a0ed061dbf80eb382fac1ea393870c7c2530649a5a41f1a5bd5e72ffb11e8ad8dd2925510e18f4528079ae532b623e6e7f38a119565df01139f58 SHA512 3f767cdf945361d81b0a89137fb1e77377cbb4171da790027cbb9cd8cf1deb03f24a8ec780b427b7bce34538e851a44682515fbaccf8558d61e22356b9d216dd
EBUILD asciidoctor-1.5.7.1.ebuild 956 BLAKE2B c6aac8ca62a7c9184b00a741ef3c2965de557f4e9075d3587e26cfd3600d042f769396286484160c86ca1293a9fd033356bf9bff2040047ae7745b154eece7da SHA512 80c28f9473ada0de74250728ae4d9954309bd96694a8aed5c51d330a49b2f18c48c82a85c4754af3e3e9f729be58ceaa6c3c19154ff96cac8c3d20a17afd5727
+EBUILD asciidoctor-1.5.8.ebuild 959 BLAKE2B 685bd493fcb88199c4a13fd164f3c7cf031d3f94b892d18d30d4ee3bb55875558efa96a41d866083fd4662a597d9803a90f4a5a1446a1137b86bd752cf4962ca SHA512 a06c7725e8a26545d13f902051c42ae265caa542f541e468da1516a792ee01d1094feef645a40a2204f893de42a88994eff3e62de9c3f6c653cfe57280c1bf34
MISC metadata.xml 349 BLAKE2B 65a3f6dbbe523d1017d78e939c291e40edc3429d06ff16bd0f8150f3879e2b0840619653115be43c876d1cfeea8e95a3e29fea7447b18bc28bb0218ac03f11c1 SHA512 e3ed6253349df933eb4656c972f1a6cc71567c27a721195abceac0d28bfbc991cbda8772f661021c3cf954d2a917730bad54982e319655a204b6b30c1c67c6d1
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.8.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.8.ebuild
new file mode 100644
index 000000000000..f9176522685d
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/thread_safe
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}