summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/asciidoctor
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/asciidoctor')
-rw-r--r--dev-ruby/asciidoctor/Manifest5
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild43
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild44
-rw-r--r--dev-ruby/asciidoctor/metadata.xml11
4 files changed, 103 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
new file mode 100644
index 000000000000..72bfd6b54af2
--- /dev/null
+++ b/dev-ruby/asciidoctor/Manifest
@@ -0,0 +1,5 @@
+DIST asciidoctor-1.5.5.tar.gz 543437 BLAKE2B ff3530825a495ee222634aa871f828069fd5c1ec1ab3c4513f7b0e74af3c4a78ee4ab0f0764f8d7dc698484d2acb962dc4fa8ae6a2c7f6c365c08a65a3044afa SHA512 6a95c2e48314a1f44d6398d83c490231baeb4ebea8d8c0e0ef361c884251fe054d48afceccadfb6c34947946920731e0194fc3e398b8dd8b8b320ea9d37f1f66
+DIST asciidoctor-1.5.7.1.tar.gz 565182 BLAKE2B c697ea1b371a9ec26ec3277e043275ed3672bad104d34553aa442723797df3cc4e5a48447f806dba53fb3a142760f514bff74b189058260f621c8b63f8ad02b1 SHA512 4819aef93fb301e5378871935370fe37671446ecdedf76853cc0c19a6a5f3f0e2debbf2afb8ba7287f866fb57903abdfe6d845e1ccf24dda4347ec9c92624c3d
+EBUILD asciidoctor-1.5.5-r1.ebuild 942 BLAKE2B 154f852f7422e2751ff609f3dfb3e8a5dcb62eb346a89d4f3a51fd8afe1a9a0d326fd412ed90bbe5bc160c26a0da025d276476a6805059a1fd5381d9bb8f0409 SHA512 13ad9922e3c2d33b800b4c2e3d3dc519c8db6a50df5204061509be75f8a7c33ecb788bcccbfef21f81315f407db1b33caf84490dd634ecc4c4fff61570cf32d4
+EBUILD asciidoctor-1.5.7.1.ebuild 958 BLAKE2B 3366671f6f5f38c071d9d028f3f4b41335b08754a8406f308f539a01c72352bf94870f631c40c25c814f25b0054cd1682975457a15f5204d90f798fa3c2fb1c8 SHA512 795b7921c26379e9fd13642216df4e120c0e3d95a14264a6e4c56cd82a50384154854132f15b304367b8019f28f52cf5207b86b5a71e84806c081573c7f0187f
+MISC metadata.xml 349 BLAKE2B 65a3f6dbbe523d1017d78e939c291e40edc3429d06ff16bd0f8150f3879e2b0840619653115be43c876d1cfeea8e95a3e29fea7447b18bc28bb0218ac03f11c1 SHA512 e3ed6253349df933eb4656c972f1a6cc71567c27a721195abceac0d28bfbc991cbda8772f661021c3cf954d2a917730bad54982e319655a204b6b30c1c67c6d1
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..bd14dd1ef17d
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild
new file mode 100644
index 000000000000..f810a893369c
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.7.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 hppa ~ppc ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/thread_safe
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}
diff --git a/dev-ruby/asciidoctor/metadata.xml b/dev-ruby/asciidoctor/metadata.xml
new file mode 100644
index 000000000000..7108bba489a1
--- /dev/null
+++ b/dev-ruby/asciidoctor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">asciidoctor/asciidoctor</remote-id>
+ </upstream>
+</pkgmetadata>