summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-ruby/asciidoctor
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-ruby/asciidoctor')
-rw-r--r--dev-ruby/asciidoctor/Manifest4
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.10.ebuild2
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild44
3 files changed, 48 insertions, 2 deletions
diff --git a/dev-ruby/asciidoctor/Manifest b/dev-ruby/asciidoctor/Manifest
index b09d4257081b..3257f55bbf42 100644
--- a/dev-ruby/asciidoctor/Manifest
+++ b/dev-ruby/asciidoctor/Manifest
@@ -1,3 +1,5 @@
DIST asciidoctor-2.0.10.tar.gz 613180 BLAKE2B 46125c85276eb0c7cf4404ca04d854449233e2cd14e24687aed9f95eb64ceb6ebac3d3ed73918679b9a5b047e41d82d02383d0e08acd0df5cc9bc216f14c79a3 SHA512 9ef908081569188d9903c7a7619fe0b50197f6f0cc922c4070e116bcd3f988a55da87443e84b6e260aabcc653a804fcaf29b96a722ab36f7ebb27ec11eb7ddbe
-EBUILD asciidoctor-2.0.10.ebuild 980 BLAKE2B 6354ab319cea99da9910e2dc39a9bdc52d9c001e873cf5321a351ebb1343d1c2e6d5907472982e2553ea62f327dc4432d7bd0ea25b36eeed2795c62c0bfb235c SHA512 f3c8b9d68dadb3f5c6b2bab76ab9532352f1bd96db23c062c16bfd570b63ea10567e1c3477d4c507a2c71536c6ae576f2d28a7b47aac8fe0368f2281090db262
+DIST asciidoctor-2.0.11.tar.gz 625446 BLAKE2B 4c4a3a7e019971765efade92da39d5895f54bd3eb927eb1ecc1cc3e3998490fcdb93426c03c9fca82d777b28c6c8027f34d39289b2250254884613670eacf9d6 SHA512 eef126653fb75c4d4bce5481f9e12f1852cf5794f547e1131f2e3f5bc34c3813e32034e6890432e83fc543b4a5dcca46750d052844d7055bfe20ea4b0c4428f2
+EBUILD asciidoctor-2.0.10.ebuild 979 BLAKE2B d525fa7b8fcedad543f7611e44e15ec0b355d6276d90dffde72eb382d5420d9b8a25867c93f47bec000f2d98eb623bcc8938faa3da8bcb43179b318bdd741b3f SHA512 b92e49a6670c6a656673ae6d357fc7574103853937b5d22714b4aa4ef5070a14569f40788d8c59977b7b5a01f1c3de23480a248c0248175c965ba19fdde4f849
+EBUILD asciidoctor-2.0.11.ebuild 948 BLAKE2B 7ea5d120583b57a119a9d74e37397984fc6ae2392965d26539554409087a32d6459904a898e12361777ea8e8303db9dd0044eacd97e0ebab9690cc7241af5d47 SHA512 67d54eede232b11f22e075662e7eb36452cc56f15252ef3dd2b23aff0c2cd49df216aebe0dd844d729e4f1b5d02150dda9e0290479ffad142ef37f60f6d01ded
MISC metadata.xml 349 BLAKE2B 65a3f6dbbe523d1017d78e939c291e40edc3429d06ff16bd0f8150f3879e2b0840619653115be43c876d1cfeea8e95a3e29fea7447b18bc28bb0218ac03f11c1 SHA512 e3ed6253349df933eb4656c972f1a6cc71567c27a721195abceac0d28bfbc991cbda8772f661021c3cf954d2a917730bad54982e319655a204b6b30c1c67c6d1
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.10.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.10.ebuild
index 29c726dd5fbf..d2ca9b0b5829 100644
--- a/dev-ruby/asciidoctor/asciidoctor-2.0.10.ebuild
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.10.ebuild
@@ -18,7 +18,7 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm ~arm64 hppa ppc ppc64 x86"
+KEYWORDS="amd64 arm arm64 hppa ppc ppc64 x86"
IUSE=""
ruby_add_bdepend "test? (
diff --git a/dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild b/dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild
new file mode 100644
index 000000000000..15d529af89d7
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-2.0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/concurrent-ruby
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/rouge
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}