summaryrefslogtreecommitdiff
path: root/dev-ruby/ascii85
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-26 15:48:02 +0000
commit38b7258d086dd5e263c3bbe3880c8c956676bc71 (patch)
tree6fce284d5bfddaf597a490ac66069d16c6a485db /dev-ruby/ascii85
parent0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (diff)
gentoo resync : 25.01.2018
Diffstat (limited to 'dev-ruby/ascii85')
-rw-r--r--dev-ruby/ascii85/Manifest2
-rw-r--r--dev-ruby/ascii85/ascii85-1.0.3.ebuild28
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/ascii85/Manifest b/dev-ruby/ascii85/Manifest
index 801e4bd01a5d..9c14bee10275 100644
--- a/dev-ruby/ascii85/Manifest
+++ b/dev-ruby/ascii85/Manifest
@@ -1,3 +1,5 @@
DIST Ascii85-1.0.2.gem 10752 BLAKE2B 1a38fb0d04eefcd73028aeb166169bf04dced4695eaa3ab8d5add8233bb898780b896101558f7db248aeb4cd9c58edaf36b67085ba0b2cb06bb32b312e576c56 SHA512 e2437948697dd46c646e55a361b74ad5069b261809a0e374eee1f3e755d07bbc45d85fc8ab6d620eceeeb020e6ff23224703cba0ce4ddf37f8a5a96289efd74b
+DIST Ascii85-1.0.3.gem 11776 BLAKE2B e08bbc089546dd3b91ff5fd85b8652dd6f5c06025c29ac67004bd7d4c7bb8fc38c77b604dd5a884970b05041e173f37eaf895f0bb9ac1947ce70e4f0cc54906c SHA512 b324ff06ea0cd46a679619a2bfca9f05c30ece9f0342f8a8d097841f3fb4dbb29cf4b6f6832742c50fe5a51895a9048308981be296466422269ce34c4d936f5c
EBUILD ascii85-1.0.2-r2.ebuild 679 BLAKE2B ff94a3d791054113a575c2a6f48f5edfd91299dd33f750006b461afdcb2a150174a50c6467b59f2c8b81251cd5795d198c131d08d5db3d6339eb5425fb1d0867 SHA512 2e9aba974fe41c7dbf6d4ca9067a09e347dbfac9fd2044e410a721b8c01868b2aaca0d4ba3468a5ba75f3f62714c1cc9a221cac7b96aa66e868ee8b4b0aceb27
+EBUILD ascii85-1.0.3.ebuild 677 BLAKE2B b26846b43d8e4adc6319cac1e49e85a1c9b0922a4db6154db94bc76d7b8fa1512bc3627bdf95d347e19b48bbde49d992e088614b40ac1bb639866e71a1ca667f SHA512 3f2c69e6c97a6a2bb4b1dc774903fac5665a4712b9853837ec60452f51429dc2a754b66e453a8cbefc85683b03316ac3e1e4da3627b3f1252547b2bc41ccdbb2
MISC metadata.xml 347 BLAKE2B 3b0a255aa723b441f953964689464ac15e6542dbab4183a32f670408039421d294eb308c0ec37d6080cbb6ebac4c43473f67ed3eb7429880fc0cada79d7bc560 SHA512 362fbd91725d86bf6694499188bdb904b99639488b2cc87f6fa7c50392790f921abb54cc8d329cac0e3f1d4cef6d24c05eb8ab8a365ddf149a7dc23dea5f72f8
diff --git a/dev-ruby/ascii85/ascii85-1.0.3.ebuild b/dev-ruby/ascii85/ascii85-1.0.3.ebuild
new file mode 100644
index 000000000000..84e2c0e63200
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name"
+HOMEPAGE="https://github.com/datawraith/ascii85gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}