summaryrefslogtreecommitdiff
path: root/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild')
-rw-r--r--dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild b/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
new file mode 100644
index 000000000000..fef2e005dabd
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.0.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name"
+HOMEPAGE="https://github.com/datawraith/ascii85gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}