summaryrefslogtreecommitdiff
path: root/dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild')
-rw-r--r--dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild b/dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild
new file mode 100644
index 000000000000..589f4b6b5d5c
--- /dev/null
+++ b/dev-ruby/arel-helpers/arel-helpers-2.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to help construct database queries"
+HOMEPAGE="https://github.com/camertron/arel-helpers"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+ruby_add_rdepend "|| (
+ dev-ruby/activerecord:5.2
+ dev-ruby/activerecord:5.1
+ dev-ruby/activerecord:5.0
+ dev-ruby/activerecord:4.2 )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rr
+ dev-ruby/activerecord[sqlite]
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/pry-/ s:^:#:' spec/spec_helper.rb || die
+}