summaryrefslogtreecommitdiff
path: root/dev-ruby/allison/allison-2.0.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/allison/allison-2.0.3-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/allison/allison-2.0.3-r3.ebuild')
-rw-r--r--dev-ruby/allison/allison-2.0.3-r3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/allison/allison-2.0.3-r3.ebuild b/dev-ruby/allison/allison-2.0.3-r3.ebuild
new file mode 100644
index 000000000000..349c93f8d150
--- /dev/null
+++ b/dev-ruby/allison/allison-2.0.3-r3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_EXTRAINSTALL="cache"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A modern, pretty RDoc template"
+HOMEPAGE="https://fauna.github.com/fauna/allison/files/README.html"
+
+LICENSE="AFL-3.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sparc x86 ~x86-solaris"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+}