summaryrefslogtreecommitdiff
path: root/dev-ruby/akismet/akismet-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/akismet/akismet-2.0.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/akismet/akismet-2.0.0.ebuild')
-rw-r--r--dev-ruby/akismet/akismet-2.0.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/akismet/akismet-2.0.0.ebuild b/dev-ruby/akismet/akismet-2.0.0.ebuild
new file mode 100644
index 000000000000..25935c3762b8
--- /dev/null
+++ b/dev-ruby/akismet/akismet-2.0.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the Akismet API"
+HOMEPAGE="https://github.com/jonahb/akismet"
+SRC_URI="https://github.com/jonahb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+# Tests now require an API key from akismet and a network connection.
+RESTRICT="test"