summaryrefslogtreecommitdiff
path: root/dev-ruby/activesupport/activesupport-5.1.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-02 17:36:40 +0100
commit171a011ad3a131671aeb5a98b9e3adf219ad2865 (patch)
tree0c877a3d1a37f10e37ad7168cfc52054aa0948a7 /dev-ruby/activesupport/activesupport-5.1.2.ebuild
parent75fc75ae1f0481ffdb78450e801a9b443ba641bd (diff)
gentoo resync : 02.04.2018
Diffstat (limited to 'dev-ruby/activesupport/activesupport-5.1.2.ebuild')
-rw-r--r--dev-ruby/activesupport/activesupport-5.1.2.ebuild65
1 files changed, 0 insertions, 65 deletions
diff --git a/dev-ruby/activesupport/activesupport-5.1.2.ebuild b/dev-ruby/activesupport/activesupport-5.1.2.ebuild
deleted file mode 100644
index f164d4cb88cd..000000000000
--- a/dev-ruby/activesupport/activesupport-5.1.2.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activesupport.gemspec"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="Utility Classes and Extension to the Standard Library"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- >=dev-ruby/concurrent-ruby-1.0.2:1
- >=dev-ruby/i18n-0.7:* =dev-ruby/i18n-0*:*
- >=dev-ruby/tzinfo-1.1:1
- >=dev-ruby/minitest-5.1:5"
-
-# memcache-client, nokogiri, and builder are not strictly
-# needed, but there are tests using this code.
-ruby_add_bdepend "test? (
- >=dev-ruby/dalli-2.2.1
- >=dev-ruby/nokogiri-1.4.5
- >=dev-ruby/builder-3.1.0
- >=dev-ruby/listen-3.0.5:3
- dev-ruby/rack
- dev-ruby/mocha:0.14
- <dev-ruby/minitest-5.4
- )"
-
-all_ruby_prepare() {
- # Set the secure permissions that tests expect.
- chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
-
- # Remove items from the common Gemfile that we don't need for this
- # test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|minitest\|sprockets\|stackprof\|rack-cache\|sqlite\)/ s:^:#:" \
- -e '/:job/,/end/ s:^:#:' \
- -e '/group :doc/,/^end/ s:^:#:' \
- -e 's/gemspec/gemspec path: "activesupport"/' \
- -e '5igem "builder"; gem "rack"' ../Gemfile || die
- rm ../Gemfile.lock || die
-
- # Avoid test that depends on timezone
- sed -i -e '/test_implicit_coercion/,/^ end/ s:^:#:' test/core_ext/duration_test.rb || die
-
- # Avoid tests that seem to trigger race conditions.
- rm -f test/evented_file_update_checker_test.rb || die
-}