summaryrefslogtreecommitdiff
path: root/dev-ruby/activejob/activejob-7.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-10 17:18:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-10 17:18:10 +0000
commit627302fc2f41a621644260ffa3f50e06ea5edd60 (patch)
tree0559b6826aa029213d2980eff2e007fa11d715ff /dev-ruby/activejob/activejob-7.0.7.ebuild
parent92e45d8c110d3b9403a141d225037f2c8ed90450 (diff)
gentoo auto-resync : 10:12:2023 - 17:18:10
Diffstat (limited to 'dev-ruby/activejob/activejob-7.0.7.ebuild')
-rw-r--r--dev-ruby/activejob/activejob-7.0.7.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/activejob/activejob-7.0.7.ebuild b/dev-ruby/activejob/activejob-7.0.7.ebuild
deleted file mode 100644
index ce3637f56cb7..000000000000
--- a/dev-ruby/activejob/activejob-7.0.7.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Job framework with pluggable queues"
-HOMEPAGE="https://github.com/rails/rails"
-SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/globalid-0.3.6
-"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha
- dev-ruby/zeitwerk
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
-
- # Remove all currently unpackaged queues.
- sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
- -e 's/delayed_job//' Rakefile || die
- sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
- rm -f test/cases/delayed_job_adapter_test.rb || die
-}