summaryrefslogtreecommitdiff
path: root/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-18 10:15:03 +0000
commitb284a3168fa91a038925d2ecf5e4791011ea5e7d (patch)
tree16fe44748708acacd909d4e2e160a09a7f6d936a /dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild
parent77398e424e45d9e98c1cef3c43bdadb9d56e81ef (diff)
gentoo resync : 18.11.2019
Diffstat (limited to 'dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild')
-rw-r--r--dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild b/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild
new file mode 100644
index 000000000000..14bce484fa62
--- /dev/null
+++ b/dev-ruby/actionpack-action_caching/actionpack-action_caching-1.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Action caching for Action Pack (removed from core in Rails 4.0)"
+HOMEPAGE="https://github.com/rails/actionpack-action_caching"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/actionpack-4.0.0:*"
+
+ruby_add_bdepend "test? ( >=dev-ruby/activerecord-4.0.0
+ dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" Rakefile test/abstract_unit.rb || die
+ sed -i -e "/git/d" ${PN}.gemspec || die
+ sed -i -e "2irequire 'mocha/setup'" test/caching_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test test/caching_test.rb || die
+}