summaryrefslogtreecommitdiff
path: root/dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild')
-rw-r--r--dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild b/dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild
index 1f39947c5636..f3818bd389e1 100644
--- a/dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild
+++ b/dev-ruby/actionmailbox/actionmailbox-7.0.2.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27"
+USE_RUBY="ruby27 ruby30"
RUBY_FAKEGEM_RECIPE_DOC="none"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -41,6 +41,7 @@ ruby_add_bdepend "test? (
dev-ruby/bundler
dev-ruby/mocha
dev-ruby/propshaft
+ dev-ruby/rexml
dev-ruby/sqlite3
dev-ruby/webmock
)"
@@ -48,7 +49,7 @@ ruby_add_bdepend "test? (
all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
- sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\|rexml\)/ s:^:#:" \
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|mysql2\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|sass-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|redis\|blade\|aws-sdk\|google-cloud\|azure-storage\|selenium\|webdrivers\|webrick\|minitest-bisect\|minitest-retry\|minitest-reporters\|listen\|rack-cache\|capybara\|webpacker\|bootsnap\|dalli\|connection_pool\)/ s:^:#:" \
-e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
-e '/group :\(cable\|doc\|job\|rubocop\|storage\|test\)/,/^end/ s:^:#:' \
-i ../Gemfile || die