summaryrefslogtreecommitdiff
path: root/dev-ruby/actioncable/actioncable-6.1.7.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 11:56:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 11:56:49 +0000
commit95b557bc48bb734c288bac87dcfe98b8ae3d1cdb (patch)
treec5ffde10d5eed804daa50794c905d6b228af7177 /dev-ruby/actioncable/actioncable-6.1.7.1.ebuild
parent3b34ca9eec2676e6fe530f34e463f52308a11441 (diff)
gentoo auto-resync : 18:01:2023 - 11:56:49
Diffstat (limited to 'dev-ruby/actioncable/actioncable-6.1.7.1.ebuild')
-rw-r--r--dev-ruby/actioncable/actioncable-6.1.7.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/actioncable/actioncable-6.1.7.1.ebuild b/dev-ruby/actioncable/actioncable-6.1.7.1.ebuild
new file mode 100644
index 000000000000..c59b8cc80841
--- /dev/null
+++ b/dev-ruby/actioncable/actioncable-6.1.7.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Integrated WebSockets for Rails"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+# Tests require many new dependencies, skipping for now
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ ~dev-ruby/activesupport-${PV}:*
+ dev-ruby/nio4r:2
+ >=dev-ruby/websocket-driver-0.6.1:*
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.2.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"