summaryrefslogtreecommitdiff
path: root/dev-ruby/actioncable/actioncable-5.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/actioncable/actioncable-5.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/actioncable/actioncable-5.0.3.ebuild')
-rw-r--r--dev-ruby/actioncable/actioncable-5.0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/actioncable/actioncable-5.0.3.ebuild b/dev-ruby/actioncable/actioncable-5.0.3.ebuild
new file mode 100644
index 000000000000..b5ff7a649d85
--- /dev/null
+++ b/dev-ruby/actioncable/actioncable-5.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Integrated WebSockets for Rails"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+# Tests require many new dependencies, skipping for now
+RESTRICT="test"
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ >=dev-ruby/nio4r-1.2:0
+ >=dev-ruby/websocket-driver-0.6.1:0 =dev-ruby/websocket-driver-0.6*
+"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/railties-4.2.0
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.14.0:0.14
+ )"