summaryrefslogtreecommitdiff
path: root/dev-ros/uuid_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/uuid_msgs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/uuid_msgs')
-rw-r--r--dev-ros/uuid_msgs/Manifest4
-rw-r--r--dev-ros/uuid_msgs/metadata.xml11
-rw-r--r--dev-ros/uuid_msgs/uuid_msgs-1.0.6.ebuild21
-rw-r--r--dev-ros/uuid_msgs/uuid_msgs-9999.ebuild21
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-ros/uuid_msgs/Manifest b/dev-ros/uuid_msgs/Manifest
new file mode 100644
index 000000000000..2aa65c77f9ce
--- /dev/null
+++ b/dev-ros/uuid_msgs/Manifest
@@ -0,0 +1,4 @@
+DIST unique_identifier-1.0.6.tar.gz 12305 BLAKE2B 3aa8ba6a7386588f56546e42efd61cc52a6a7c44444462c55f26830e162eafbc49a7aaca2315d965d75f8f0151467147af7db8a0fbe96def66c33e81371e069c SHA512 d81409786a311fd1d23937fd24bf0365920f6b9cd7b4ba9803935844c0dab0a1765b2790f88673fe8fffea70ff13161ddadc7644bc8d39e3f0c255007b267156
+EBUILD uuid_msgs-1.0.6.ebuild 529 BLAKE2B 1d638cfc2df8624563448b9f1b7eec52f9a07a87e6e3fc00db3bd34bfe884d14dec04fe7701cd3b2098cc5373381463aff12ddb43277e8dad3053171067571b6 SHA512 ef792fe6b06a20a5c65996b31b92cc510d764200c7347c7bf3d7d9581fcfe00e5ef9ba5b0b319a23d20478917789b86c18a5855d981edc1bc1921dfbeab88936
+EBUILD uuid_msgs-9999.ebuild 529 BLAKE2B 1d638cfc2df8624563448b9f1b7eec52f9a07a87e6e3fc00db3bd34bfe884d14dec04fe7701cd3b2098cc5373381463aff12ddb43277e8dad3053171067571b6 SHA512 ef792fe6b06a20a5c65996b31b92cc510d764200c7347c7bf3d7d9581fcfe00e5ef9ba5b0b319a23d20478917789b86c18a5855d981edc1bc1921dfbeab88936
+MISC metadata.xml 351 BLAKE2B 263bd97d8a235f46caee579594b8c44e0f638ba246459a9b7090da4fafdbafcc26a8fca2716c005a2cfb4dac98def55e691744d7ce869528032652b2f7fda96e SHA512 8636c13070578878bd780ee448a76c3a5040758e23f5c1e990bd433fdf91a3645294210d172917317715f806d87dac379a023979a555c68270e0c79319c4b659
diff --git a/dev-ros/uuid_msgs/metadata.xml b/dev-ros/uuid_msgs/metadata.xml
new file mode 100644
index 000000000000..07abf56c1b23
--- /dev/null
+++ b/dev-ros/uuid_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-geographic-info/unique_identifier</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/uuid_msgs/uuid_msgs-1.0.6.ebuild b/dev-ros/uuid_msgs/uuid_msgs-1.0.6.ebuild
new file mode 100644
index 000000000000..2536e3890222
--- /dev/null
+++ b/dev-ros/uuid_msgs/uuid_msgs-1.0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS messages for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild b/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild
new file mode 100644
index 000000000000..2536e3890222
--- /dev/null
+++ b/dev-ros/uuid_msgs/uuid_msgs-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros-geographic-info/unique_identifier"
+VER_PREFIX=unique_identifier-
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS messages for universally unique identifiers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"