summaryrefslogtreecommitdiff
path: root/dev-ros/timestamp_tools/files/tests.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/timestamp_tools/files/tests.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/timestamp_tools/files/tests.patch')
-rw-r--r--dev-ros/timestamp_tools/files/tests.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/dev-ros/timestamp_tools/files/tests.patch b/dev-ros/timestamp_tools/files/tests.patch
new file mode 100644
index 000000000000..c73d09a1b1ac
--- /dev/null
+++ b/dev-ros/timestamp_tools/files/tests.patch
@@ -0,0 +1,14 @@
+Index: driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+===================================================================
+--- driver_common-1.6.8.orig/timestamp_tools/CMakeLists.txt
++++ driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+@@ -17,5 +17,7 @@ install(DIRECTORY include/${PROJECT_NAME
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
+ FILES_MATCHING PATTERN "*.h")
+
++if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(test_trigger_matcher test/test_trigger_matcher.cpp)
+-target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
+\ No newline at end of file
++target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
++endif()