summaryrefslogtreecommitdiff
path: root/dev-ros/theora_image_transport
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/theora_image_transport
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/theora_image_transport')
-rw-r--r--dev-ros/theora_image_transport/Manifest5
-rw-r--r--dev-ros/theora_image_transport/metadata.xml11
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild32
-rw-r--r--dev-ros/theora_image_transport/theora_image_transport-9999.ebuild32
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-ros/theora_image_transport/Manifest b/dev-ros/theora_image_transport/Manifest
new file mode 100644
index 000000000000..b6438b3ddaab
--- /dev/null
+++ b/dev-ros/theora_image_transport/Manifest
@@ -0,0 +1,5 @@
+DIST image_transport_plugins-1.9.5.tar.gz 26268 SHA256 a3dcd3af617bcafba5b8dab5fbd89183fbaf31798ee4e4e63a91059fa110168c SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c WHIRLPOOL 1796f983cd0a904b6cce58ecec4a59034ab23ca8ca7a3c2a9b3fa8764d60c1426754c3a6bdb9eaf8bcff1859768af76b3d4f3a3350ee6cd6af5cc89f90ae639a
+EBUILD theora_image_transport-1.9.5.ebuild 762 SHA256 56b45f2d7c2feebca8eb71907b5f50c60b823b73654fd286384b87291a19e43d SHA512 f77af82079dd0a65a8a468a35d403de6b40ea5a285896d453e1eb1b45b8ab36dc5bfbcb3b9a7a534b5a910b245838d9303fb848ec50c41d1c3c8e4569324b9ee WHIRLPOOL da112d37aa39a2dc719ecfee0f77365b72fb053fb906e83812fe4a39543837c4ec61e621287d2187d910b94143424a1b1bb4991ff43025461e378da424555921
+EBUILD theora_image_transport-9999.ebuild 762 SHA256 56b45f2d7c2feebca8eb71907b5f50c60b823b73654fd286384b87291a19e43d SHA512 f77af82079dd0a65a8a468a35d403de6b40ea5a285896d453e1eb1b45b8ab36dc5bfbcb3b9a7a534b5a910b245838d9303fb848ec50c41d1c3c8e4569324b9ee WHIRLPOOL da112d37aa39a2dc719ecfee0f77365b72fb053fb906e83812fe4a39543837c4ec61e621287d2187d910b94143424a1b1bb4991ff43025461e378da424555921
+MISC ChangeLog 1981 SHA256 65b2735f8ffd7f0f5eb23fd39fbc6d4f510c5748d058b1cf3942c58b142b9cf9 SHA512 4c60eec51d95aa94ff5eaa8caf9273c084c226ded39d5c41c03cea28502ce1b518f5df681dd39b0fccfa6d7ad82932fadd4ad2a5495cbd8a7ae9449a67e0431d WHIRLPOOL 9c047462007dc1524c0b10c0cd86623f0b2f66fea219690aaa556e397be10030b9235056b875853739376d0c1412d083db0c3e9642ed6503a676e30940cece36
+MISC metadata.xml 352 SHA256 7531295b37e1b7807944e69f310c2892596e0fe8ed15decb854b1c687ce48422 SHA512 855c756eea98c52acb020fb394646008db35b41b864a0983f67bbf07ffce658d394c0de13d6622286770e4aa4152b74f2f6028c575b11b66233431d1fffa0347 WHIRLPOOL e87c5707d2ab0f2d6e03b845b2fffa93bb023722d1d6635013e4341052c5bd58bc6010ab0e82ed9959f80cdfb68383bc395f8752f0cd6f6d20b708c78a3cec5c
diff --git a/dev-ros/theora_image_transport/metadata.xml b/dev-ros/theora_image_transport/metadata.xml
new file mode 100644
index 000000000000..feed05c03f5b
--- /dev/null
+++ b/dev-ros/theora_image_transport/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/image_transport_plugins</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild b/dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild
new file mode 100644
index 000000000000..d66dc1d1f7c8
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-1.9.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ media-libs/opencv
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild b/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
new file mode 100644
index 000000000000..d66dc1d1f7c8
--- /dev/null
+++ b/dev-ros/theora_image_transport/theora_image_transport-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending an image stream encoded with the Theora codec"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_transport
+ media-libs/opencv
+ dev-ros/rosbag
+ dev-ros/pluginlib
+ media-libs/libogg
+ media-libs/libtheora[encode]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"