summaryrefslogtreecommitdiff
path: root/dev-ros/tf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-25 08:07:03 +0000
commita1b20429e7e2ba1b44414459afd5a2b50788cd9c (patch)
treee721db30ecc3e534a03ab9b3115762959cc0c28c /dev-ros/tf
parentdbbd2ae5e62a232616ede4dae3ed69e15903940a (diff)
gentoo auto-resync : 25:01:2023 - 08:07:03
Diffstat (limited to 'dev-ros/tf')
-rw-r--r--dev-ros/tf/Manifest5
-rw-r--r--dev-ros/tf/files/yaml.patch13
-rw-r--r--dev-ros/tf/metadata.xml11
-rw-r--r--dev-ros/tf/tf-1.13.2-r4.ebuild41
-rw-r--r--dev-ros/tf/tf-9999.ebuild41
5 files changed, 0 insertions, 111 deletions
diff --git a/dev-ros/tf/Manifest b/dev-ros/tf/Manifest
deleted file mode 100644
index 803c9933a3c5..000000000000
--- a/dev-ros/tf/Manifest
+++ /dev/null
@@ -1,5 +0,0 @@
-AUX yaml.patch 559 BLAKE2B 228004c7cc268ebe011dfc8f83aeec9a32e98566c970b7e94b8fcd19879ad1974038fdee9b850ca7bebc770e96cf8b81a92ae9583188191de86e7d5a4100b835 SHA512 67f8aeee746fc3137310fc5eb127d8dc12be2c33b38b2237b6889f7837d2637125394ebe5d22c6dfee28787fecf0cf48be3168c09a50c435dde7040eed39dfc3
-DIST geometry-1.13.2.tar.gz 188225 BLAKE2B b08e78b298c94c38baa5d25a878be703d7d3a310277b66690b9fe4da1d0cd3f9083cf3bf6dc1d59149599b6fb0ec10feaf668206da245ed7e0cb9cf1878b620c SHA512 504de0e7ebf1dd73e918ab4fa39967cc9e39a53d487072430106b391d669ddfc7e530b66b38f4f73d1787e4a73acdad8e707c6757afe2e235157d4aa19f28af2
-EBUILD tf-1.13.2-r4.ebuild 1168 BLAKE2B ad119ddebd7ebbf5a63645858bc3f1de1d8dd398e064485d5fa4394409561808c2c4d8c359858bea04c07430361351c197ec5a0ea4dace494988e43f63b887cd SHA512 70623099f220705f029d0285bc2d02d631bd982b4e3f5bbcbbd2dad13542a05f2d3d3678e8e8601f845ce4d4944a5264cf04fa7ea3f5b38c7b12fef5b7eb2a57
-EBUILD tf-9999.ebuild 1168 BLAKE2B ad119ddebd7ebbf5a63645858bc3f1de1d8dd398e064485d5fa4394409561808c2c4d8c359858bea04c07430361351c197ec5a0ea4dace494988e43f63b887cd SHA512 70623099f220705f029d0285bc2d02d631bd982b4e3f5bbcbbd2dad13542a05f2d3d3678e8e8601f845ce4d4944a5264cf04fa7ea3f5b38c7b12fef5b7eb2a57
-MISC metadata.xml 327 BLAKE2B 566ab6c75daafd1554630fd8762bebc05fa3a002b3f785b59a69d77653167d6d2c0cce2e20067ead12cd5075da7c7d6e40f70e21b4628e419c43252c6d878500 SHA512 fd1f0d017b6a422df2fcdd7797ec631ac8b2afaa706338848b941c39e4d3d82549969f0018162da22cb9499a114a4a4a58a945b284585b30c7eff589ecf975d5
diff --git a/dev-ros/tf/files/yaml.patch b/dev-ros/tf/files/yaml.patch
deleted file mode 100644
index 344ef80417ae..000000000000
--- a/dev-ros/tf/files/yaml.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: tf/src/tf/listener.py
-===================================================================
---- tf.orig/src/tf/listener.py
-+++ tf/src/tf/listener.py
-@@ -94,7 +94,7 @@ class Transformer(object):
-
- def getFrameStrings(self):
- """ Not a recommended API, only here for backwards compatibility """
-- data = yaml.load(self._buffer.all_frames_as_yaml()) or {}
-+ data = yaml.safe_load(self._buffer.all_frames_as_yaml()) or {}
- return [p for p, _ in data.items()]
-
- def getLatestCommonTime(self, source_frame, dest_frame):
diff --git a/dev-ros/tf/metadata.xml b/dev-ros/tf/metadata.xml
deleted file mode 100644
index 0717de2e0623..000000000000
--- a/dev-ros/tf/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ros@gentoo.org</email>
- <name>Gentoo ROS Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">ros/geometry</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ros/tf/tf-1.13.2-r4.ebuild b/dev-ros/tf/tf-1.13.2-r4.ebuild
deleted file mode 100644
index 77026fbea1aa..000000000000
--- a/dev-ros/tf/tf-1.13.2-r4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-CATKIN_HAS_MESSAGES=yes
-ROS_REPO_URI="https://github.com/ros/geometry"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Maintains the relationship between frames in a tree structure over time"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-ros/angles:0
- dev-ros/message_filters
- dev-ros/rosconsole
- dev-ros/rostime
- dev-ros/roscpp
- dev-ros/tf2_ros
- dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
- dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
- $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? (
- dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
- )"
-PATCHES=( "${FILESDIR}/yaml.patch" )
diff --git a/dev-ros/tf/tf-9999.ebuild b/dev-ros/tf/tf-9999.ebuild
deleted file mode 100644
index 77026fbea1aa..000000000000
--- a/dev-ros/tf/tf-9999.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-CATKIN_HAS_MESSAGES=yes
-ROS_REPO_URI="https://github.com/ros/geometry"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Maintains the relationship between frames in a tree structure over time"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-libs/boost:=
- dev-ros/angles:0
- dev-ros/message_filters
- dev-ros/rosconsole
- dev-ros/rostime
- dev-ros/roscpp
- dev-ros/tf2_ros
- dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
- dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
- $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
- test? (
- dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
- dev-cpp/gtest
- $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
- )"
-PATCHES=( "${FILESDIR}/yaml.patch" )