summaryrefslogtreecommitdiff
path: root/dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild')
-rw-r--r--dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild b/dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild
new file mode 100644
index 000000000000..007bd064fc2d
--- /dev/null
+++ b/dev-ros/tf2_tools/tf2_tools-0.6.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 tools"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/tf2_py[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"