summaryrefslogtreecommitdiff
path: root/dev-ros/test_tf2/test_tf2-0.5.17.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-07 18:44:07 +0000
commit5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (patch)
tree0528a53855a7ec96d20cde9edb9031aab030224c /dev-ros/test_tf2/test_tf2-0.5.17.ebuild
parenta8b0d35ab742f31538d515dea39716e566d533c0 (diff)
gentoo resync : 07.01.2018
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-0.5.17.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-0.5.17.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/test_tf2/test_tf2-0.5.17.ebuild b/dev-ros/test_tf2/test_tf2-0.5.17.ebuild
new file mode 100644
index 000000000000..9bfecde03150
--- /dev/null
+++ b/dev-ros/test_tf2/test_tf2-0.5.17.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="TF2 unit tests"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/tf
+ dev-ros/tf2
+ dev-ros/tf2_bullet
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_msgs
+ sci-libs/orocos_kdl
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+ dev-cpp/gtest"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )