summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild')
-rw-r--r--dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild b/dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild
new file mode 100644
index 000000000000..2e62994a05c3
--- /dev/null
+++ b/dev-ros/test_rosmaster/test_rosmaster-1.15.13.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosmaster"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${PYTHON_SINGLE_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_SINGLE_USEDEP}] )
+"
+
+mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
+
+src_install() {
+ ros-catkin_src_install
+ dodir /usr/share/${PN}
+ cp -a test "${ED}//usr/share/${PN}/" || die
+}