summaryrefslogtreecommitdiff
path: root/dev-ros/smach_msgs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/smach_msgs
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/smach_msgs')
-rw-r--r--dev-ros/smach_msgs/Manifest5
-rw-r--r--dev-ros/smach_msgs/metadata.xml11
-rw-r--r--dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild21
-rw-r--r--dev-ros/smach_msgs/smach_msgs-9999.ebuild21
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-ros/smach_msgs/Manifest b/dev-ros/smach_msgs/Manifest
new file mode 100644
index 000000000000..873f418ea276
--- /dev/null
+++ b/dev-ros/smach_msgs/Manifest
@@ -0,0 +1,5 @@
+DIST executive_smach-2.0.1.tar.gz 42032 SHA256 2f7f58064c960fc56de15fdedfd883f62122bd44874787f13c8b4d8a77c45380 SHA512 88be9ad6a0ec1e82e1592d26621fbbfe24e45640266f369cd03f192649bfd865e5a4ea576cf665161c0f89805e67b38b8b64b62a054ca1e217b99d8284f3b32a WHIRLPOOL 69b12a64c5826e27447e2e5adbff9462369d41b1e6b2e88561b758c19019c8233400a98e01146b8a34b38f66ad9678cf58a8373fed72d07640bb56fb9a26256d
+EBUILD smach_msgs-2.0.1.ebuild 506 SHA256 2124ff96e9e2a53dba0a62678a7a111afc303cf9326c8cdaedb32c2fbfe78967 SHA512 adc687d877cc1e7e8550b7912ca0d3f88b6861696e05a41db8be3e7c08ec2ee4fffd1d1169a1f00a865bdd88462a917d35b7a12adbd44bca253e83ff7e9dbd31 WHIRLPOOL db9aae4b7af6d504873a5abfe600d27ea09e35aaec8631182944859dc0406e254404fce643bca682cd394de7ecf6fbfb9c73646ac68ca460b3314d00ca0043c5
+EBUILD smach_msgs-9999.ebuild 506 SHA256 2124ff96e9e2a53dba0a62678a7a111afc303cf9326c8cdaedb32c2fbfe78967 SHA512 adc687d877cc1e7e8550b7912ca0d3f88b6861696e05a41db8be3e7c08ec2ee4fffd1d1169a1f00a865bdd88462a917d35b7a12adbd44bca253e83ff7e9dbd31 WHIRLPOOL db9aae4b7af6d504873a5abfe600d27ea09e35aaec8631182944859dc0406e254404fce643bca682cd394de7ecf6fbfb9c73646ac68ca460b3314d00ca0043c5
+MISC ChangeLog 1449 SHA256 5e0195c2e7a41fdb4f69dbc2f3e35ae42cbf0dc5842d6aff93d32602da852a30 SHA512 434f9b71b9a2dd5c4527e78fb324cdd9de2be5a58e013e20eb66d1579d663ed83f14c883d148d07fb88d457e5d58d012c94b47487ad93b44dad5e39bc87e148e WHIRLPOOL 241fc3354dadfa9141629a5eb16d86ace4f2af2840c2b6548c4b8986088ec9f5a3615ad556949a2cc1305dd3af4f2c9431012ea76aad2bb55fee47277bb06a86
+MISC metadata.xml 333 SHA256 aba7e1e3d7e1c5145de75631ba8ee9879b2493edf82ee68130b40be069aa584d SHA512 c5e649958133658717bd4d1723953187a4c9626c7a1143fa784bc10ef533165bcb386248a42e20e9c1f7de4147e34c5a09f1009c5c65a78e2ed8fa0ccfc56165 WHIRLPOOL 76736ea4dd79d710af018a8524c95d52f984228853da631ed11e1aed7f70cc79b96dbde61d94429430b081731daf4b58ffd77e411c6a20425dec153cb0362280
diff --git a/dev-ros/smach_msgs/metadata.xml b/dev-ros/smach_msgs/metadata.xml
new file mode 100644
index 000000000000..d2fce8b37504
--- /dev/null
+++ b/dev-ros/smach_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/executive_smach</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild b/dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild
new file mode 100644
index 000000000000..5bacb8924912
--- /dev/null
+++ b/dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Set of messages that are used by the introspection interfaces for smach"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/smach_msgs/smach_msgs-9999.ebuild b/dev-ros/smach_msgs/smach_msgs-9999.ebuild
new file mode 100644
index 000000000000..5bacb8924912
--- /dev/null
+++ b/dev-ros/smach_msgs/smach_msgs-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Set of messages that are used by the introspection interfaces for smach"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"