summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-15 16:58:00 +0000
commit434d713861b70f6c6563d6ee50a8e64f14c970d9 (patch)
treeb72c523c72e764420f835ba9d63d43ffef687dcf /dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild
parentf78108598211053d41752a83e0345441bb9014ae (diff)
gentoo resync : 15.02.2018
Diffstat (limited to 'dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild')
-rw-r--r--dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild b/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild
new file mode 100644
index 000000000000..00637e917afc
--- /dev/null
+++ b/dev-ros/rqt_reconfigure/rqt_reconfigure-0.4.9.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_reconfigure"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides the way to view and edit the parameters that are accessible via dynamic_reconfigure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_console[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"