summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_publisher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/rqt_publisher
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/rqt_publisher')
-rw-r--r--dev-ros/rqt_publisher/Manifest6
-rw-r--r--dev-ros/rqt_publisher/metadata.xml11
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-0.4.7.ebuild28
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild27
-rw-r--r--dev-ros/rqt_publisher/rqt_publisher-9999.ebuild27
5 files changed, 99 insertions, 0 deletions
diff --git a/dev-ros/rqt_publisher/Manifest b/dev-ros/rqt_publisher/Manifest
new file mode 100644
index 000000000000..237f3713e92e
--- /dev/null
+++ b/dev-ros/rqt_publisher/Manifest
@@ -0,0 +1,6 @@
+DIST rqt_common_plugins-0.4.7.tar.gz 246977 BLAKE2B 5efebfa64dcc587822e558b5527a2ef2e33adc8adcb45800876e278be5ccdacbaef93b0f9dfbb7b98972fd5cffb4fcddee80e9522a4135a736d744765c2490ed SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7
+DIST rqt_publisher-0.4.8.tar.gz 10391 BLAKE2B 558aef7e411dcf500fe3bf1a76985dd63c9f4b1936dd878fad22a61aab03206a10325f81329cfba24105cd041e28b389da009ceabd559c55b68e6b4411c8aae1 SHA512 87a325c9599b68171f5e014524946ab0a311872035c8b23a7234f17854d7e7f91916a6db856331b5e9958d098197b55a2e799a5b0d232bb32dd420acd070421e
+EBUILD rqt_publisher-0.4.7.ebuild 747 BLAKE2B 136e5d7efce4fcca79a1c629628cf1bb845f96b7d2b1c651b52db77a895792ee9510c08a9b982bc163b2306baef4bbfd697d598a3de74e5fc93fcaa59a4353bb SHA512 e33938c765d1562a8ab2fed03b941e43c25e0015fd7ffcd7c393d09188f3fb82fa874fee0bfd661d2a687f9c0fc1a101538780b2408976e0b4692e1f989cdf85
+EBUILD rqt_publisher-0.4.8.ebuild 725 BLAKE2B 43e0ed68f81ad401bb1455e040809f3363bd68dbd4389594492c23b93fe7df3d76b712282b890d650453496209b07124a933bcbe0cf42c15e3f0bc0f3b904450 SHA512 a5e9edd38ed24ce1fa4d33409ab881451c372daeb110b104ea25d8709d919b4677f38b1152e7ed5e3cb2233ef6046787a6d7aca08a4e4a23a5d1d2ad7b371072
+EBUILD rqt_publisher-9999.ebuild 725 BLAKE2B 43e0ed68f81ad401bb1455e040809f3363bd68dbd4389594492c23b93fe7df3d76b712282b890d650453496209b07124a933bcbe0cf42c15e3f0bc0f3b904450 SHA512 a5e9edd38ed24ce1fa4d33409ab881451c372daeb110b104ea25d8709d919b4677f38b1152e7ed5e3cb2233ef6046787a6d7aca08a4e4a23a5d1d2ad7b371072
+MISC metadata.xml 345 BLAKE2B 64fc91bbd538f31ef418ae121fafc1ce9cb7cf8f5372883954025473563996800c4ebb5a04126ad897eab0f3393a477eac23d58fe1a702c915b6354c67f47e0f SHA512 8483076bb71220bf91931889a48412b23865e964fbf05182b726e498add7bfddfab59c2cf56161ad39af79628bfbb69be25e18a2aa7535b97bfbdada7dd21cb6
diff --git a/dev-ros/rqt_publisher/metadata.xml b/dev-ros/rqt_publisher/metadata.xml
new file mode 100644
index 000000000000..db9114451292
--- /dev/null
+++ b/dev-ros/rqt_publisher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt_publisher</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_publisher/rqt_publisher-0.4.7.ebuild b/dev-ros/rqt_publisher/rqt_publisher-0.4.7.ebuild
new file mode 100644
index 000000000000..c205c17bfb7c
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-0.4.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild b/dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild
new file mode 100644
index 000000000000..b4dc8d08ed02
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-0.4.8.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_publisher"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
new file mode 100644
index 000000000000..b4dc8d08ed02
--- /dev/null
+++ b/dev-ros/rqt_publisher/rqt_publisher-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_publisher"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for publishing arbitrary messages with fixed or computed field values"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"