summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_gui_cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/rqt_gui_cpp
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/rqt_gui_cpp')
-rw-r--r--dev-ros/rqt_gui_cpp/Manifest5
-rw-r--r--dev-ros/rqt_gui_cpp/metadata.xml11
-rw-r--r--dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.0.ebuild26
-rw-r--r--dev-ros/rqt_gui_cpp/rqt_gui_cpp-9999.ebuild26
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_cpp/Manifest b/dev-ros/rqt_gui_cpp/Manifest
new file mode 100644
index 000000000000..ddfd391ace82
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/Manifest
@@ -0,0 +1,5 @@
+DIST rqt-0.5.0.tar.gz 120992 SHA256 3f62f90db254e111483b9a7cb9d486d0bf07c863b2a987808dc3636ee7004c22 SHA512 5c91fe9bce5a7cb0cdc54b42667488d30c33bd57afd30cc8f2047b91b7aa7b8afd936090bfc76be5dbc8c6497623c1be4340e061503f5a65bc94faaad810597e WHIRLPOOL 1c6ac80ad727a3bc11898036b08fb5d1d1b56fc5dabc4328816018b79709407c3b7cdb095a85fbadff17730b91c33825a77f6756252b527b2c467f5366eade8c
+EBUILD rqt_gui_cpp-0.5.0.ebuild 504 SHA256 484f42802bf3f6ac32b9ab33b90a0af8ca5166bc00b2533254602751ada715c0 SHA512 4e0fa661afc32b1da4ce70717ef3ef9f800156510402f7052039a3a57ed9c508371195c06aba4a8569ae156d69d689f61bfcc3721990e64c0063450eca8c78e2 WHIRLPOOL 8539cb2e35f0e0fb97e9ac47241a58943e63fe8c5d08eccbfb68e6306552188c47b0dbdee5e2bdaa1f2b6009959a099bd33283b4bc55d4120587fef044b8da3c
+EBUILD rqt_gui_cpp-9999.ebuild 504 SHA256 484f42802bf3f6ac32b9ab33b90a0af8ca5166bc00b2533254602751ada715c0 SHA512 4e0fa661afc32b1da4ce70717ef3ef9f800156510402f7052039a3a57ed9c508371195c06aba4a8569ae156d69d689f61bfcc3721990e64c0063450eca8c78e2 WHIRLPOOL 8539cb2e35f0e0fb97e9ac47241a58943e63fe8c5d08eccbfb68e6306552188c47b0dbdee5e2bdaa1f2b6009959a099bd33283b4bc55d4120587fef044b8da3c
+MISC ChangeLog 1750 SHA256 e626ec1737a7c666cb7e3df83fb584e397ac92b153d84c77205fb4b6c0b50425 SHA512 1f8ca0f9f5553532e702f2418327743a38d13f6fe66b2d682d9554895e0c748fc706e3c8b74fca5860a7b27c7d37094d0ac3e777872b3efdb8de92c8315040b5 WHIRLPOOL 47d5dba685409361c76dd9ae02199597428a54734606923fb84a21889764e20025af715571031f3cf8e46388014168c690eca84be54e19cc76aec59a3d9e8971
+MISC metadata.xml 335 SHA256 8c6967251ca6f8968c808ab9b3b346de4daed46a49f4759f2da81b558ba6f92a SHA512 d861666a6188e5bce041f76eedc1c3c18c8f1a185b5481e16f57481d7836f4fd71e9fb04b6f0c58c0cf4f5f77595e7675e2761699efdb2f697ec76cd6d0941f4 WHIRLPOOL 8b8f6bc528d59b8448f4cd3193a33fa860672e17d502f4f975db7cfbea24bdaf120db727646164cad223386f19e054c9501bafa46088b5912f5b5ea9c50b6b50
diff --git a/dev-ros/rqt_gui_cpp/metadata.xml b/dev-ros/rqt_gui_cpp/metadata.xml
new file mode 100644
index 000000000000..a016c2096bc5
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.0.ebuild b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.0.ebuild
new file mode 100644
index 000000000000..fba4d8107a8e
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-0.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the C++ client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ >=dev-ros/qt_gui_cpp-0.3.0
+ >=dev-ros/qt_gui-0.3.0
+ dev-ros/roscpp
+ dev-ros/nodelet
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_gui_cpp/rqt_gui_cpp-9999.ebuild b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-9999.ebuild
new file mode 100644
index 000000000000..fba4d8107a8e
--- /dev/null
+++ b/dev-ros/rqt_gui_cpp/rqt_gui_cpp-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the C++ client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtwidgets:5
+ dev-qt/qtcore:5
+ >=dev-ros/qt_gui_cpp-0.3.0
+ >=dev-ros/qt_gui-0.3.0
+ dev-ros/roscpp
+ dev-ros/nodelet
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"