summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-15 02:11:33 +0100
commit0fdd4074ff3dc0c507a9867380a4f91250a0b610 (patch)
tree83d3b64438d2f29b375d895f12b82d5c484db219 /dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild
parent8fbd420dce8836e6503b162092e07b6a77a89f1d (diff)
gentoo resync : 15.10.2017
Diffstat (limited to 'dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild')
-rw-r--r--dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild b/dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild
new file mode 100644
index 000000000000..9131e47b8514
--- /dev/null
+++ b/dev-ros/rqt_bag/rqt_bag-0.4.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_bag"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for displaying and replaying ROS bag files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"