summaryrefslogtreecommitdiff
path: root/dev-ros/rostime/rostime-0.7.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-20 14:45:01 +0100
commit34dea8e38f88007799629d0a56b12dec480b1d21 (patch)
tree6790873994b58030360328cf5897d934b3b03d16 /dev-ros/rostime/rostime-0.7.2-r1.ebuild
parent7932d472a02d4c016ff7dff4b7a5479ab9d1883d (diff)
gentoo resync : 20.06.2021
Diffstat (limited to 'dev-ros/rostime/rostime-0.7.2-r1.ebuild')
-rw-r--r--dev-ros/rostime/rostime-0.7.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rostime/rostime-0.7.2-r1.ebuild b/dev-ros/rostime/rostime-0.7.2-r1.ebuild
new file mode 100644
index 000000000000..9d76e62d902b
--- /dev/null
+++ b/dev-ros/rostime/rostime-0.7.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/roscpp_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Time and Duration implementations for C++ libraries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads(+)]
+ dev-ros/cpp_common
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+"