summaryrefslogtreecommitdiff
path: root/dev-ros/rosmake/rosmake-1.14.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-ros/rosmake/rosmake-1.14.6.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-ros/rosmake/rosmake-1.14.6.ebuild')
-rw-r--r--dev-ros/rosmake/rosmake-1.14.6.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/rosmake/rosmake-1.14.6.ebuild b/dev-ros/rosmake/rosmake-1.14.6.ebuild
new file mode 100644
index 000000000000..734dd611a6f8
--- /dev/null
+++ b/dev-ros/rosmake/rosmake-1.14.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_5} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS dependency aware build tool"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"