summaryrefslogtreecommitdiff
path: root/dev-ros/roslz4/roslz4-1.14.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-07 11:42:03 +0100
commitf70601e0934acd62f6c5d06c5ede4cc607179514 (patch)
tree0b337390375de04b950fc4b45edc0f895a4701a4 /dev-ros/roslz4/roslz4-1.14.2.ebuild
parentb2be182d49eea46686b5cf2680d457df61e89dc4 (diff)
gentoo resync : 07.07.2018
Diffstat (limited to 'dev-ros/roslz4/roslz4-1.14.2.ebuild')
-rw-r--r--dev-ros/roslz4/roslz4-1.14.2.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/roslz4/roslz4-1.14.2.ebuild b/dev-ros/roslz4/roslz4-1.14.2.ebuild
new file mode 100644
index 000000000000..0e76c772bc3a
--- /dev/null
+++ b/dev-ros/roslz4/roslz4-1.14.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ implementation of the LZ4 streaming format"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/lz4"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"