summaryrefslogtreecommitdiff
path: root/dev-ros/roslz4/roslz4-1.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ros/roslz4/roslz4-1.13.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ros/roslz4/roslz4-1.13.0.ebuild')
-rw-r--r--dev-ros/roslz4/roslz4-1.13.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/roslz4/roslz4-1.13.0.ebuild b/dev-ros/roslz4/roslz4-1.13.0.ebuild
new file mode 100644
index 000000000000..873188d0c0af
--- /dev/null
+++ b/dev-ros/roslz4/roslz4-1.13.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=utilities/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python and C++ implementation of the LZ4 streaming format"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="app-arch/lz4"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"