summaryrefslogtreecommitdiff
path: root/dev-ros/rosbag
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /dev-ros/rosbag
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'dev-ros/rosbag')
-rw-r--r--dev-ros/rosbag/Manifest2
-rw-r--r--dev-ros/rosbag/rosbag-1.13.6.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/rosbag/Manifest b/dev-ros/rosbag/Manifest
index 2db7d1d9618c..a51f51f50128 100644
--- a/dev-ros/rosbag/Manifest
+++ b/dev-ros/rosbag/Manifest
@@ -1,4 +1,6 @@
DIST ros_comm-1.13.5.tar.gz 1027857 BLAKE2B ed2611179bc7f84bf0b9cde1336474a3bc4c3980ebf97241910123abd430a48ae0636a6ddfb6c191bea2905454644c7ec340e26049d8faddca39783bef13d60b SHA512 91af2de897851061eda140d6c96ec88171f1fd1cd7549b6df1ac570e066603c7bb721a58cb19487657387753433d67ad22421408a237d1ffb5ea580c0cf3eeb3
+DIST ros_comm-1.13.6.tar.gz 1047870 BLAKE2B 874e31faa1a6a77292dab4b7fa64ed13a1f1f63f76512ea351e53bd14ce87662cea5c648e48c3c16668104129cc5eb172bc8f381516bdba676c7212f1acbaaf9 SHA512 382e81847141ab95462fc84a8215b945af995d29f9c0d507665e22faaf79aee9789950546ca7737bd40059f3ed1ecd284ff11bd3e6f1732f3c47a433c5d25155
EBUILD rosbag-1.13.5-r1.ebuild 788 BLAKE2B aaff3aaa1cd2185386f03d77b1077af54dfe8db1679a0e188c30cdca8c405c471c13fffda3cc33427b9bf1a05b1dbfa774b49adcb2a03bbdcdea9bdc8c5f2f61 SHA512 eb722337ca6e9626ea86a2f0de133b3d649d71f2331463a81357f4f0cb6eae4c6f7e75648bacfa6a3184b1d9deccc1083948426f06d51ccfb3565b9b4686b636
+EBUILD rosbag-1.13.6.ebuild 788 BLAKE2B e79eae884ca24580a8a18e819a55720c74e7d6f5239600336f1664bee61b77467cf86e905a7f65c254b156b6a6e6d9211461a32ca2ca215cec5aac4da43c7d44 SHA512 4378dc8403f94b286cb4ca54a53f8006ef317b1ca343e6fa5e424ee4da972a7cc862d0f19a397afff98c004c012246133d32b60b8ebc727713dda6603ebe9fbc
EBUILD rosbag-9999.ebuild 788 BLAKE2B aaff3aaa1cd2185386f03d77b1077af54dfe8db1679a0e188c30cdca8c405c471c13fffda3cc33427b9bf1a05b1dbfa774b49adcb2a03bbdcdea9bdc8c5f2f61 SHA512 eb722337ca6e9626ea86a2f0de133b3d649d71f2331463a81357f4f0cb6eae4c6f7e75648bacfa6a3184b1d9deccc1083948426f06d51ccfb3565b9b4686b636
MISC metadata.xml 418 BLAKE2B 2d84b96bfb428654a9b926100a8bd083afb2addc6db8b2e6fb003fab4bb8c1615df40ee13c863a3ddfe98a1a1f9b72af8310a80a9f610a01fe14366afde2e38d SHA512 d7579d9a25bf9f83513e3d8058ec845ee9b59e5d999128532b63d992cee8ef94922aee88140f044829442077c6f9ae80d6b0b0f554cf677690fdc88a17c9f260
diff --git a/dev-ros/rosbag/rosbag-1.13.6.ebuild b/dev-ros/rosbag/rosbag-1.13.6.ebuild
new file mode 100644
index 000000000000..0517a514bb8d
--- /dev/null
+++ b/dev-ros/rosbag/rosbag-1.13.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools for recording from and playing back to ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE="lz4"
+
+RDEPEND="
+ dev-ros/rosbag_storage
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/topic_tools
+ dev-ros/xmlrpcpp
+ dev-libs/boost:=
+ app-arch/bzip2
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/genpy[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ lz4? ( dev-ros/roslz4[${PYTHON_USEDEP}] )"