summaryrefslogtreecommitdiff
path: root/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-21 18:59:32 +0100
commit520a5b56dff7c24c9d42eafec142cb78b44f8e3e (patch)
treef562f705600dbd2292e97c0b4145787c2a8d1f97 /dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild
parent3811bc3072bf19e2be351d2c63f81532945c0f21 (diff)
gentoo resync : 21.07.2018
Diffstat (limited to 'dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild')
-rw-r--r--dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild b/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild
new file mode 100644
index 000000000000..216e47f8341e
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-1.12.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"