summaryrefslogtreecommitdiff
path: root/dev-ros/qt_gui_cpp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/qt_gui_cpp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/qt_gui_cpp')
-rw-r--r--dev-ros/qt_gui_cpp/Manifest5
-rw-r--r--dev-ros/qt_gui_cpp/files/libdir.patch15
-rw-r--r--dev-ros/qt_gui_cpp/metadata.xml11
-rw-r--r--dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.8-r1.ebuild34
-rw-r--r--dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild34
5 files changed, 99 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_cpp/Manifest b/dev-ros/qt_gui_cpp/Manifest
new file mode 100644
index 000000000000..6e2e24d914c7
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/Manifest
@@ -0,0 +1,5 @@
+AUX libdir.patch 1151 BLAKE2B f78ed19cff2df00514da0e60b6cfbda581443a0b7b1515a7c40d1a9518391611de3c5ff9eed6091ac2dbbdff168aba14239ac21754657541aa5b6e053e19aa7d SHA512 a6393e452f9a2a2517d35e2edb069f94acc8461dfda631c3183099a9b8bf6aa79bd5747ef1e1275637ad3fbbca67bab0aa9bcb21dce1f3eb67ed2600ceffe657
+DIST qt_gui_core-0.3.8.tar.gz 91248 BLAKE2B 9ed159b8d065e7b2a44dcf9ac496a699675e5ec41d5ed222413894f098e122b092c976c934dc37a99846e0fe80858fb377bf937b3eabc3f0c6df126de7944e88 SHA512 aec926adffc9f1ab84d7d5cccb207d87254496b37e9e2e4c430de191917823424751206647d61821a65dec0aad3241dab22c85f21980fbe1a4bf114bb2c29d70
+EBUILD qt_gui_cpp-0.3.8-r1.ebuild 745 BLAKE2B 2f7e609d3f4336951307b9ba559969a437bf68f44a4695d333791fb9ccc7057a23c85048060812b232bc9c20ffd1a0c3c96bd341c53fb0bbda12230815c6be1d SHA512 776fa23e75d92cbf557fbcee6742f0fd18dbac87af5aa3640aded8e5775c59eac1294c22403bbf86a8ada2c205ca629e88f627ac82bffcd2f01c3e19f2c87060
+EBUILD qt_gui_cpp-9999.ebuild 745 BLAKE2B 2f7e609d3f4336951307b9ba559969a437bf68f44a4695d333791fb9ccc7057a23c85048060812b232bc9c20ffd1a0c3c96bd341c53fb0bbda12230815c6be1d SHA512 776fa23e75d92cbf557fbcee6742f0fd18dbac87af5aa3640aded8e5775c59eac1294c22403bbf86a8ada2c205ca629e88f627ac82bffcd2f01c3e19f2c87060
+MISC metadata.xml 343 BLAKE2B 518da938afd557552bcb4eec225723207d73325a348640eb5280137715941f95190d8be30f52d1773e97cb80c9ed25b34d60ed7cfdbb5425e6b6d30bb1a2050b SHA512 88a9c15a6f681122449cff3b89c4805a0a9ee5d579e1eb98f4814e6e57d3adafb0e370986a6e68c555880b80fb900d74ffd4cb19a670c15e3d0f5fa383e39810
diff --git a/dev-ros/qt_gui_cpp/files/libdir.patch b/dev-ros/qt_gui_cpp/files/libdir.patch
new file mode 100644
index 000000000000..8c22eed2385c
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/files/libdir.patch
@@ -0,0 +1,15 @@
+Index: qt_gui_core-0.2.26/qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
+===================================================================
+--- qt_gui_core-0.2.26.orig/qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
++++ qt_gui_core-0.2.26/qt_gui_cpp/src/qt_gui_cpp_sip/CMakeLists.txt
+@@ -29,8 +29,8 @@ set(qt_gui_cpp_sip_DEPENDENT_FILES
+ # maintain context for different named target
+ set(qt_gui_cpp_sip_INCLUDE_DIRS ${qt_gui_cpp_INCLUDE_DIRS} "${CMAKE_CURRENT_SOURCE_DIR}/../../include" ${catkin_INCLUDE_DIRS})
+ set(qt_gui_cpp_sip_LIBRARIES ${qt_gui_cpp_LIBRARIES} ${PROJECT_NAME} ${catkin_LIBRARIES} ${Boost_LIBRARIES})
+-set(qt_gui_cpp_sip_LIBRARY_DIRS ${qt_gui_cpp_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/lib)
+-set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER} -Wl,-rpath,\\"${CATKIN_DEVEL_PREFIX}/lib\\")
++set(qt_gui_cpp_sip_LIBRARY_DIRS ${qt_gui_cpp_LIBRARY_DIRS} ${CATKIN_DEVEL_PREFIX}/${CMAKE_INSTALL_LIBDIR})
++set(qt_gui_cpp_sip_LDFLAGS_OTHER ${qt_gui_cpp_LDFLAGS_OTHER} -Wl,-rpath,\\"${CATKIN_DEVEL_PREFIX}/${CMAKE_INSTALL_LIBDIR}\\")
+
+ find_package(python_qt_binding REQUIRED)
+ include(${python_qt_binding_EXTRAS_DIR}/sip_helper.cmake)
diff --git a/dev-ros/qt_gui_cpp/metadata.xml b/dev-ros/qt_gui_cpp/metadata.xml
new file mode 100644
index 000000000000..bd9f89f114ce
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/qt_gui_core</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.8-r1.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.8-r1.ebuild
new file mode 100644
index 000000000000..0216c3788c0b
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/qt_gui_cpp-0.3.8-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ >=dev-ros/pluginlib-1.9.23
+ dev-libs/tinyxml2:=
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/tinyxml
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/libdir.patch"
+)
diff --git a/dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild b/dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild
new file mode 100644
index 000000000000..0216c3788c0b
--- /dev/null
+++ b/dev-ros/qt_gui_cpp/qt_gui_cpp-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Foundation for C++-bindings for dev-ros/qt_gui and creates bindings for every generator available"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtwidgets:5
+ >=dev-ros/pluginlib-1.9.23
+ dev-libs/tinyxml2:=
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/tinyxml
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/libdir.patch"
+)