summaryrefslogtreecommitdiff
path: root/dev-ros/python_qt_binding
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/python_qt_binding
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/python_qt_binding')
-rw-r--r--dev-ros/python_qt_binding/Manifest6
-rw-r--r--dev-ros/python_qt_binding/metadata.xml11
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.2.ebuild20
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild20
-rw-r--r--dev-ros/python_qt_binding/python_qt_binding-9999.ebuild20
5 files changed, 77 insertions, 0 deletions
diff --git a/dev-ros/python_qt_binding/Manifest b/dev-ros/python_qt_binding/Manifest
new file mode 100644
index 000000000000..57694550284c
--- /dev/null
+++ b/dev-ros/python_qt_binding/Manifest
@@ -0,0 +1,6 @@
+DIST python_qt_binding-0.3.2.tar.gz 12047 BLAKE2B 330ab27cface576d37cfca709a9758b6499a181b8e2734c04ef0f55b84a3d45a4ae821fbf572337e71115b4db57839f900e406b9ce8b3cfc71daa2d4ff4b143c SHA512 777d7ba00652d34994648615125f6c426170a1723570de35b9e5a060d0f077b563a57c9b0cbe7bd85a7ed2f5f011797e9102918a27df4f0096831cce0bb80304
+DIST python_qt_binding-0.3.3.tar.gz 12114 BLAKE2B 12a2e785746ec3d9fe7b387a9e727bfacb5e37da90702c728c8e874c52cd3e4cfc000936d8f17cefbeeb98673de8c21f066eded743df3b5325b88e785f3dc100 SHA512 0dfd698b390a87e0619e93a291656c329ff37713411c5a805e720aeedf9fefd43fc780bbdba351cd1a73e30d67ce8e93a98b5ba6b5584a807d829611ac232263
+EBUILD python_qt_binding-0.3.2.ebuild 464 BLAKE2B 4640d5f2755764535c55f415e3b013409f15a27db23a154bbe5c4d090e51f2be48a969081b5f688ba999b942dd20aca4f8868aa9857161165501df1371663e7a SHA512 ddccf3c99f45ec8d37e18ecd3fc84a2560bb06d03df32b57198c20589137f53ab39af42fcd75c2f5ea01d6a00f2a0718964190698ce54e28d5ffe40a3b18f7d9
+EBUILD python_qt_binding-0.3.3.ebuild 464 BLAKE2B 4640d5f2755764535c55f415e3b013409f15a27db23a154bbe5c4d090e51f2be48a969081b5f688ba999b942dd20aca4f8868aa9857161165501df1371663e7a SHA512 ddccf3c99f45ec8d37e18ecd3fc84a2560bb06d03df32b57198c20589137f53ab39af42fcd75c2f5ea01d6a00f2a0718964190698ce54e28d5ffe40a3b18f7d9
+EBUILD python_qt_binding-9999.ebuild 464 BLAKE2B 4640d5f2755764535c55f415e3b013409f15a27db23a154bbe5c4d090e51f2be48a969081b5f688ba999b942dd20aca4f8868aa9857161165501df1371663e7a SHA512 ddccf3c99f45ec8d37e18ecd3fc84a2560bb06d03df32b57198c20589137f53ab39af42fcd75c2f5ea01d6a00f2a0718964190698ce54e28d5ffe40a3b18f7d9
+MISC metadata.xml 349 BLAKE2B bc205c9c90eab1ea292d3e90f9f4a1d769c5202af60c57371152eaf80a50bdf6257cb2bb0ad6070a8443f0d19cc64e8493d5ec43e2701085f96c90ec6187a705 SHA512 f388f612a53c2de0a6cdece5a03d08e583f848592da6763b7995ff80e60756caca49da4318ded57ba09141facf717442141066142ed0691172f4e6b98a5ee266
diff --git a/dev-ros/python_qt_binding/metadata.xml b/dev-ros/python_qt_binding/metadata.xml
new file mode 100644
index 000000000000..e70e86cf84c7
--- /dev/null
+++ b/dev-ros/python_qt_binding/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/python_qt_binding</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.2.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.2.ebuild
new file mode 100644
index 000000000000..9e4951a61c85
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild b/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild
new file mode 100644
index 000000000000..9e4951a61c85
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-0.3.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
new file mode 100644
index 000000000000..9e4951a61c85
--- /dev/null
+++ b/dev-ros/python_qt_binding/python_qt_binding-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/python_qt_binding"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit ros-catkin
+
+DESCRIPTION="Infrastructure for an integrated graphical user interface based on Qt"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"