summaryrefslogtreecommitdiff
path: root/dev-ros/poco_vendor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-ros/poco_vendor
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-ros/poco_vendor')
-rw-r--r--dev-ros/poco_vendor/Manifest4
-rw-r--r--dev-ros/poco_vendor/metadata.xml11
-rw-r--r--dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild37
-rw-r--r--dev-ros/poco_vendor/poco_vendor-9999.ebuild37
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-ros/poco_vendor/Manifest b/dev-ros/poco_vendor/Manifest
new file mode 100644
index 000000000000..8305f840fa36
--- /dev/null
+++ b/dev-ros/poco_vendor/Manifest
@@ -0,0 +1,4 @@
+DIST poco_vendor-1.2.0.tar.gz 3145 BLAKE2B 6143f73ec9f741ff72147ac43d4876cb17553d8a4ba33d54b60f546cd2988389de4cbc1b3fcb0300f507f91610ba64284515a3d736417f611c3ffa6eb32d5aba SHA512 f38f00028ad1b6b236305761f53748597f1203e267488ba2a08b8c06ad155338a2c413b3e5e5501becdb09aec4600ae700d95765a5b4d0861b163e4f2a9ee413
+EBUILD poco_vendor-1.2.0.ebuild 749 BLAKE2B 740f8b6ee10ae7f50d9dd14d3847cbf3d1ce24d6079f5886f8aeeb1948b0ac9f01dde14bce7c865b0496a24720e2795d0a886cf426642f5353ad6e84b34fa6ff SHA512 180212b1ca13f214c51c20417a27d5fcc930ea5bbece30092c05c031a53ada75bee8dc677f5e8eed1d0664100313266fd4dc5b7069efbb266848db04ad03c5d3
+EBUILD poco_vendor-9999.ebuild 749 BLAKE2B 740f8b6ee10ae7f50d9dd14d3847cbf3d1ce24d6079f5886f8aeeb1948b0ac9f01dde14bce7c865b0496a24720e2795d0a886cf426642f5353ad6e84b34fa6ff SHA512 180212b1ca13f214c51c20417a27d5fcc930ea5bbece30092c05c031a53ada75bee8dc677f5e8eed1d0664100313266fd4dc5b7069efbb266848db04ad03c5d3
+MISC metadata.xml 330 BLAKE2B 7880b16541c752a5d4fb5e729d4305ca3f6430a4fddb36ced24cbf6f2c75964cfbbc34ea8a16cd306b8d49412c822a17d4cf44639f1e2cb7218c437aa2500830 SHA512 b9af45457315c529a21cf6d3ca9711513aa662cf21b9de1eba6a4a0498c28525cd6175878836d5c90c72afcef201bea2ef54e50a2103d4c7c07156b6bbfbc908
diff --git a/dev-ros/poco_vendor/metadata.xml b/dev-ros/poco_vendor/metadata.xml
new file mode 100644
index 000000000000..c3d00f27cbd9
--- /dev/null
+++ b/dev-ros/poco_vendor/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros2/poco_vendor</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
new file mode 100644
index 000000000000..b6214810f35f
--- /dev/null
+++ b/dev-ros/poco_vendor/poco_vendor-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/poco_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/poco_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CMake shim over the poco library"
+HOMEPAGE="https://github.com/ros2/poco_vendor"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-libs/poco
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"
diff --git a/dev-ros/poco_vendor/poco_vendor-9999.ebuild b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
new file mode 100644
index 000000000000..b6214810f35f
--- /dev/null
+++ b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-any-r1
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ros2/poco_vendor"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/ros2/poco_vendor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="CMake shim over the poco library"
+HOMEPAGE="https://github.com/ros2/poco_vendor"
+
+LICENSE="Apache-2.0 Boost-1.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+DEPEND="
+ dev-libs/poco
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(python_gen_any_dep 'ros-meta/ament_cmake[${PYTHON_USEDEP}]')
+ ${PYTHON_DEPS}
+"