summaryrefslogtreecommitdiff
path: root/dev-ros/pluginlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/pluginlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/pluginlib')
-rw-r--r--dev-ros/pluginlib/Manifest7
-rw-r--r--dev-ros/pluginlib/files/catkin_prefix_path2.patch15
-rw-r--r--dev-ros/pluginlib/metadata.xml11
-rw-r--r--dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild27
-rw-r--r--dev-ros/pluginlib/pluginlib-1.12.1.ebuild27
-rw-r--r--dev-ros/pluginlib/pluginlib-9999.ebuild27
6 files changed, 114 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
new file mode 100644
index 000000000000..4be11cb2c0a1
--- /dev/null
+++ b/dev-ros/pluginlib/Manifest
@@ -0,0 +1,7 @@
+AUX catkin_prefix_path2.patch 678 BLAKE2B c494700f8d2cfce884b65ef87963cbf414dc4af1a9c9390978e7f458ad7f93b28c54bcd9831ff3edf4d6a421c4ec9ad1859bafff5f8ed209662ea1d14a70c299 SHA512 3b91fac26a2e48087fc70a773f5416e6cc3f7758adcddea6d50ba97a2d1ff8ae2f14fd5b74ba043a5546a8809def8b2154c70a97b10c451ba3773a82eda67100
+DIST pluginlib-1.12.0.tar.gz 20298 BLAKE2B 9d6e5adb6bd64f02d237fa1992402cb016266071c0fa0447709880f90550f36f9e280163a3e054594235d0102f7fb22f4b98a56216b0db9ebaa200b99d018570 SHA512 fcd51908c6c7223bbe50eb43733ba6d00e11419b26d2b9a05aaaf6498020fcd44bacc19313c3a4dd7524bf69d4f54aec27e05b1f88ee578191484c53c1e3f767
+DIST pluginlib-1.12.1.tar.gz 19619 BLAKE2B e91fb15b4857fae10012a71df606f5040d5a62bdee596695c873808790eea02cd380eedda6c438388264003d7ac930ebc2c649a421411580dd095365c93d3c8e SHA512 1a15cd934c4f93fecf32d7d3cab1ee6caae61d59aa65d1f796ab2ba63d5204a6fe28744c28eac80d304bd802b184afe79ead621b3c370c6d3526a944c144d724
+EBUILD pluginlib-1.12.0-r1.ebuild 639 BLAKE2B 15f141f8d152ee3eb19190a25de826335497cf5f6a9d4916a1c3c8c36eabc0435634ec1bed7f2a94787d8a58199eb42c1470a8783d9e4142ca6c6afab350c75c SHA512 032ed001238c0999a3bcd9eaf541328978af79af2ff5b95ac146b81c57c4c0948a20dc8aa07ff102754447940f2fad02612258432c4b51dfea2dab6e8f54d29d
+EBUILD pluginlib-1.12.1.ebuild 639 BLAKE2B 15f141f8d152ee3eb19190a25de826335497cf5f6a9d4916a1c3c8c36eabc0435634ec1bed7f2a94787d8a58199eb42c1470a8783d9e4142ca6c6afab350c75c SHA512 032ed001238c0999a3bcd9eaf541328978af79af2ff5b95ac146b81c57c4c0948a20dc8aa07ff102754447940f2fad02612258432c4b51dfea2dab6e8f54d29d
+EBUILD pluginlib-9999.ebuild 639 BLAKE2B 15f141f8d152ee3eb19190a25de826335497cf5f6a9d4916a1c3c8c36eabc0435634ec1bed7f2a94787d8a58199eb42c1470a8783d9e4142ca6c6afab350c75c SHA512 032ed001238c0999a3bcd9eaf541328978af79af2ff5b95ac146b81c57c4c0948a20dc8aa07ff102754447940f2fad02612258432c4b51dfea2dab6e8f54d29d
+MISC metadata.xml 327 BLAKE2B f94cb82ca7e89f9c45d423a4b56a573d7d220a5bf218838163659dc027554338b845539ae4090df944e0053ce3e0264c0323a442732619147116a583926fc405 SHA512 cf53258133948a2b0d201af3f0d439f5dcfc9c43691ae4d2b175a70258dd26ffd0fd99511aa02df57cfafb8fc4a1a8185759de0b23f7a1496a227f706900b7a2
diff --git a/dev-ros/pluginlib/files/catkin_prefix_path2.patch b/dev-ros/pluginlib/files/catkin_prefix_path2.patch
new file mode 100644
index 000000000000..12e759c63216
--- /dev/null
+++ b/dev-ros/pluginlib/files/catkin_prefix_path2.patch
@@ -0,0 +1,15 @@
+Honour CATKIN_PREFIX_PATH at runtime instead of ROS' hack to use CMAKE_PREFIX_PATH.
+
+Index: pluginlib-1.11.2/include/pluginlib/class_loader_imp.hpp
+===================================================================
+--- pluginlib-1.11.2.orig/include/pluginlib/class_loader_imp.hpp
++++ pluginlib-1.11.2/include/pluginlib/class_loader_imp.hpp
+@@ -68,7 +68,7 @@ namespace
+ std::vector<std::string> catkinFindLib()
+ {
+ std::vector<std::string> lib_paths;
+- const char * env = std::getenv("CMAKE_PREFIX_PATH");
++ const char * env = std::getenv("CATKIN_PREFIX_PATH");
+ if (env) {
+ std::string env_catkin_prefix_paths(env);
+ std::vector<std::string> catkin_prefix_paths;
diff --git a/dev-ros/pluginlib/metadata.xml b/dev-ros/pluginlib/metadata.xml
new file mode 100644
index 000000000000..1ce6591b34a6
--- /dev/null
+++ b/dev-ros/pluginlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/pluginlib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild b/dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..5346810670b3
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )
diff --git a/dev-ros/pluginlib/pluginlib-1.12.1.ebuild b/dev-ros/pluginlib/pluginlib-1.12.1.ebuild
new file mode 100644
index 000000000000..5346810670b3
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.12.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )
diff --git a/dev-ros/pluginlib/pluginlib-9999.ebuild b/dev-ros/pluginlib/pluginlib-9999.ebuild
new file mode 100644
index 000000000000..5346810670b3
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )