summaryrefslogtreecommitdiff
path: root/dev-ros/openni2_camera/openni2_camera-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ros/openni2_camera/openni2_camera-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ros/openni2_camera/openni2_camera-9999.ebuild')
-rw-r--r--dev-ros/openni2_camera/openni2_camera-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-ros/openni2_camera/openni2_camera-9999.ebuild b/dev-ros/openni2_camera/openni2_camera-9999.ebuild
index 4c4df556466d..53fb4e7fb0d0 100644
--- a/dev-ros/openni2_camera/openni2_camera-9999.ebuild
+++ b/dev-ros/openni2_camera/openni2_camera-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-drivers/openni2_camera"
CATKIN_HAS_MESSAGES=yes
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -18,12 +17,13 @@ IUSE=""
RDEPEND="
dev-ros/image_transport
dev-ros/camera_info_manager
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure[${PYTHON_SINGLE_USEDEP}]
dev-ros/nodelet
dev-libs/console_bridge:=
dev-ros/roscpp
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-libs/OpenNI2
dev-libs/boost:=[threads]
"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"