summaryrefslogtreecommitdiff
path: root/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-23 04:19:44 +0000
commitc5283d322accc6097afec74eab24550829788bab (patch)
treeb99ce668128d82a026eaa31461643f9173f9b77b /dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild
parent5510d9d7d1c93c2ea71a2bd6f0666168808d5dd6 (diff)
gentoo resync : 23.03.2018
Diffstat (limited to 'dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild')
-rw-r--r--dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild
new file mode 100644
index 000000000000..4a1844edbbaa
--- /dev/null
+++ b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Common nodelet tools such as a mux, demux and throttle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/pluginlib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"