summaryrefslogtreecommitdiff
path: root/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-18 18:38:22 +0000
commita5956e0a0daddcad648e0d8d8e5cb3e49e09bda7 (patch)
tree3d2e0a61f348a5299e73ca7c2b236156a8cc79b5 /dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild
parent38f60b3ec9ff175535d9a056a76ae42931e61e21 (diff)
gentoo resync : 18.11.2017
Diffstat (limited to 'dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild')
-rw-r--r--dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild
new file mode 100644
index 000000000000..a1bacb86bc80
--- /dev/null
+++ b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Common nodelet tools such as a mux, demux and throttle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/pluginlib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"