summaryrefslogtreecommitdiff
path: root/dev-ros/nodelet/nodelet-1.9.16-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/nodelet/nodelet-1.9.16-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/nodelet/nodelet-1.9.16-r1.ebuild')
-rw-r--r--dev-ros/nodelet/nodelet-1.9.16-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/nodelet/nodelet-1.9.16-r1.ebuild b/dev-ros/nodelet/nodelet-1.9.16-r1.ebuild
new file mode 100644
index 000000000000..8dc05c79a9af
--- /dev/null
+++ b/dev-ros/nodelet/nodelet-1.9.16-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a way to run multiple algorithms in the same process with zero copy transport"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/bondcpp
+ dev-ros/cmake_modules
+ dev-ros/pluginlib
+ dev-libs/tinyxml2:=
+ dev-ros/rosconsole
+ dev-libs/console_bridge:=
+ dev-ros/roscpp
+ dev-libs/boost:=
+ sys-apps/util-linux
+ dev-ros/class_loader:=
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"