summaryrefslogtreecommitdiff
path: root/dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild')
-rw-r--r--dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild b/dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild
new file mode 100644
index 000000000000..1688c0e60047
--- /dev/null
+++ b/dev-ros/move_slow_and_clear/move_slow_and_clear-1.15.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Move slow and clear"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/nav_core
+ dev-ros/costmap_2d
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-libs/boost:=[threads]
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+
+"