summaryrefslogtreecommitdiff
path: root/dev-ros/monocam_settler/files/gcc6.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ros/monocam_settler/files/gcc6.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ros/monocam_settler/files/gcc6.patch')
-rw-r--r--dev-ros/monocam_settler/files/gcc6.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/monocam_settler/files/gcc6.patch b/dev-ros/monocam_settler/files/gcc6.patch
new file mode 100644
index 000000000000..35c84d1fa40f
--- /dev/null
+++ b/dev-ros/monocam_settler/files/gcc6.patch
@@ -0,0 +1,22 @@
+Index: monocam_settler/CMakeLists.txt
+===================================================================
+--- monocam_settler.orig/CMakeLists.txt
++++ monocam_settler/CMakeLists.txt
+@@ -16,7 +16,7 @@ catkin_package(DEPENDS actionlib actionl
+ )
+
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+
+ # deal with the include
+@@ -33,7 +33,7 @@ install(TARGETS ${PROJECT_NAME}
+ )
+
+ # deal with the executable
+-include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
++include_directories(${Boost_INCLUDE_DIRS})
+ add_executable(monocam_settler_action src/monocam_settler_action.cpp)
+ target_link_libraries(monocam_settler_action ${Boost_LIBRARIES}
+ ${catkin_LIBRARIES}